Polaris RZR Forum - RZR Forums.net banner

1 - 20 of 74 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter #1
Has anyone noticed the top speed on the new S models seems to be higher? Although I only have a few hours on mine and didn't want to hold the throttle open/in one spot for too long, I noticed quite a bit more speed than my previous 2010 unit. On the same stretch of road by my house, which is a slight downhill, the 2010 would hit the speed limiter about midway through the run at the 63 mph advertised top limit. On the 2011, I thought the speedo was not right so I grabbed the gps and did two runs and found the speedo was dead nuts accurate!!! I hit an amazing 68 mph, bone stock and on the same stretch the 2010 was hitting 63. Now, granted, the 2010 was bouncing off the limiter so it might have gone faster if it could. However, I never felt any limiter kick in at all and this thing was still pulling when I let off! Has anyone else experienced this or do I just have a "good" one? Whatever it is, I'm loving it!!! BTW, this speed was with a driver and passenger, probably 250 pounds total.
 

·
Registered
Joined
·
209 Posts
Discussion Starter #3
I saw 6100 the one time I glanced at it, don't know if it was higher or not as I wanted to lift since the motor is still tight. I'm not sure what the difference is but if it ain't broke, then don't fix it!!! It has my curiosity up as well.
 

·
Registered
Joined
·
15,386 Posts
Ya. Let us know what you find out on further test runs.
I don't think they changed the clutch, so there would not be any overdrive there...
 

·
Registered
Joined
·
209 Posts
Discussion Starter #5
The clutch in this unit is definitely different than the 2010 clutch. It feels almost like driving with one foot on the gas and another on the brake until you get over 35 mph. When you let off the throttle, it slows down with little to no brake and does not disengage until it drops down to around 5 mph!!! The 2010 unit free wheeled from 20 on down. I did notice this unit was built toward the end of August so it has to be one of the early ones. I was not aware of them changing the clutching like this. Truthfully, the first 5 minutes of riding, I was wanting the 2010 back but now, it's growing on me!!
 

·
Registered
Joined
·
15,386 Posts
hmm,,, I just looked at the drawings of the 2011 clutch and don't see anything different that would give you more engine braking or higher top speed.

 

·
Registered
Joined
·
209 Posts
Discussion Starter #7
This is getting even more curious!!! This clutch ain't even close to the same setup as the last one. Maybe I got lucky!! Below 35 mph, I never touch the brakes unless I am coming to a complete stop. On the top end, the darn thing was still pulling at 68 and I have yet to feel any kind of limiter kick in!!
 

·
Registered
Joined
·
15,386 Posts
What was the build date on your 2010 that you are comparing the 2011 to?

There was a bearing change on 1-1-10 that is in the 2011 also:

17 3514609 Bearing, Needle [Built 1/01/10 and After] 1 Usage
17 1521185 Asm., Bearing [Built 12/31/09 and Before] 1 Usage
18 5632328 Spacer, Clutch, PM [Built 1/01/10 and After] 1 Usage
18 5632060 Spacer, Clutch [Built 12/31/09 and Before] 1 Usage
 

·
Registered
Joined
·
5,414 Posts
wow! just might have to take my 11 out for a speed run!
 

·
Registered
Joined
·
148 Posts
my 2011 goes 65 easy with 2 passengers, same deal. didnt hold it very long, and never felt a limiter either.
 

·
Registered
Joined
·
15,386 Posts
They did change the EFI system in the 2011 and claimed better fuel mileage... and changed the head with better flow... so maybe something else changed too...
 

·
Registered
Joined
·
81 Posts
I saw somewhere, a magazine video or Polaris news release video where they mention adding some engine braking.

Scoddee
 

·
Registered
Joined
·
5,414 Posts
just got back from a speed run, and i hit 67-68 mph down the road!!! clutching is spot on. revs to 6250-6300 when i floor it, and stays there till 55-60, then over-revs to 6500 and the rev limiter kicks in. this thing is fast! seems to be quicker than my 08, with higher top speed.
 

·
Registered
Joined
·
1,864 Posts
The clutch in this unit is definitely different than the 2010 clutch.
No the 2011 has exactly the same components from primary, weights, springs and secondary as the 10 does, ive researched all the part numbers and usage table on the polaris parts lookup sight and it is identical . What is different is some of the parts in the transmission which seems to make it lower geared thru low and midrange.
 

·
Registered
Joined
·
5,414 Posts
not sure on what is or isn't different on the clutch for 2011, but i am looking forward to waving to my buddy as i pass him in his 08 (built motor)
 

·
Premium Member
Joined
·
444 Posts
We just got a 11 rzr4. I only put about 3 hrs on it myself. One thing I did notice is, it seems like the 4x4 doesnt work as well as our 10 models. Almost got stuck in the sand a couple times, where our 10 model just seemed it wouldnt. I watched for the front to kick in, and it did, but too late. Seems to let the rear dig down before the front kicked in.. maybe I got a bad one.. havent checked top speed yet, but will soon and get back to you on that !!
 

·
Registered
Joined
·
164 Posts
hi guys,

i've never posted here before. i've owned my '11 for 6-7 weeks now and have had it up to 68 mph also on the flat highway. i was a little surprised since the factory stated it had a 63 mph govenor yet the needle just sailed on past. pretty happy with my new little toy!

by the way, some one asked what was top rpm...mine hit 6600rpm max spot on at 68mph.

-steve
 

·
Registered
Joined
·
2,051 Posts
Has anyone noticed the top speed on the new S models seems to be higher? Although I only have a few hours on mine and didn't want to hold the throttle open/in one spot for too long, I noticed quite a bit more speed than my previous 2010 unit. On the same stretch of road by my house, which is a slight downhill, the 2010 would hit the speed limiter about midway through the run at the 63 mph advertised top limit. On the 2011, I thought the speedo was not right so I grabbed the gps and did two runs and found the speedo was dead nuts accurate!!! I hit an amazing 68 mph, bone stock and on the same stretch the 2010 was hitting 63. Now, granted, the 2010 was bouncing off the limiter so it might have gone faster if it could. However, I never felt any limiter kick in at all and this thing was still pulling when I let off! Has anyone else experienced this or do I just have a "good" one? Whatever it is, I'm loving it!!! BTW, this speed was with a driver and passenger, probably 250 pounds total.
Can you please go test it again not going down a slight down hill? No hurry here complete your break in.

Any mods like a roof or windshield that would increase wind resistance and drag on your new or old RZR?
 
1 - 20 of 74 Posts
Top