Polaris RZR Forum - RZR Forums.net banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Warning for long post.....and I suck as a mechanic.

My aunt's rzr 800 was dumped in a river. She paid a stealership to put a rebuilt engine in it and clean it up. A year later she wants to dump it cause it does not run right.

I take it to see what I can do. It starts up, but tops out at 4000 rpm and won't go higher.

I replace the fuel pump. Replace the spark plugs. And starts up and seems to be running well in the garage. I run it for a minute or 2, then dies on me. Never to start again....
I did get it to backfire a few times with wide open throttle while starting.
Since then....
Replaced starter solenoid, cps, coil, plug wires.
If I unplugg the cps, the ecu will give me an error appropriately.
Help???
 

·
Registered
Joined
·
129 Posts
Would it rev up to max RPM in neutral or Park?
Starting and running ok but not up shifting under load to run up to max RPM often indicates a secondary clutch problem rather than anything wrong with the engine.
 

·
Premium Member
2020 900 Trail Fox Edition
Joined
·
1,181 Posts
Welcome to the forum its a great place to get your questions answered. Just to clarify when you say "I did get it to backfire with WOT while starting" check your manual these should start without touching the throttle. JMHO
 

·
Registered
Joined
·
3 Posts
Hi, I don't know if I'm in the right place to start a discussion, or ask a question but here goes, I just got a 2011 800 efi two seater and it seems to run well, but when driving it, the speedometer dies and a check engine light comes on, then just as fast, it turns off and the speed needle picks back up, and I does this over and over intermittently.......any ideas? BTW... It does NOT throw codes.
 
1 - 7 of 7 Posts
Top