Polaris RZR Forum - RZR Forums.net banner

1 - 5 of 5 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1 (Edited)
OK guys and gal, My RZR shut off last weekend and found Fuel pump is not coming on so I removed it and tested by connecting 12vdc to terminals on pump and in runs fine (also bought new pump from AutoZone) so I am getting no power to pump. Replaced 14 dollar fuel relay along with EFI fuse with new one still no power to pump. Does the ECU also control the fuel pump operation? Could this be my problem all together, bad ECU. I removed it and there was no moisture in the plug or the ECU that was noticeable but I can hear something rattling inside the ECU case like something broke loose. Any help will be greatly appreciated.

OK opened ECU and found a pc of the circuit board broken loose (round pc seems to have been connected to lower corner of board) this cant be good and possible my problem, but again will the ECU being bad keep the fuel pump from coming on?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
RZR has new ignition switch, performed on board diag. and recieved codes: 41, 51, 52, 56. wrote codes down and cleared codes by disconnecting Battery (20min) no codes after that where present. Replaced EFI solenoid, checked all connection found no problems visable, checked wiring to fuse box (had dielectric grease on everything electrical prior to any problems so corrosion was minimal) went ahead a replaced all fuses anyway though.Removed ECU and heard a loose piece in case so opened and out came a piece of the control board that had broken off some how (under warranty still) Most of the codes before where probly from no fuel getting to injectors.
Either way spoke with my mech and he said bring it in and it should all be covered under warranty and since ECU has broke Piece it has to be replaced either way.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #5
Right I thought it odd that piece came loose and broke off like that myself but after speaking with a few polaris guru's it has happened before and more often than expected on both the ATV's and UTV's
 
1 - 5 of 5 Posts
Top