Broken Rear Shock Mount - Polaris RZR Forum - RZR Forums.net
RZR XP Turbo Discuss the Polaris RZR XP Turbo EPS here!

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old October 6th, 2018, 01:04 PM Thread Starter
 
Mark Wendorf's Avatar
 
Member #260718
Join Date: Sep 2018
Posts: 13
Feedback Score: 0 reviews
View Mark Wendorf's Photo Gallery(0)
Broken Rear Shock Mount

I need the bottom shock mount for one of the rear shocks on my 16 Turbo. It snapped when my radius rod bolt broke. Do I need to call Fox to get a replacement? They just unscrew correct?
Mark Wendorf is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
XP front and rear shock swap completed on my 1000S heartburns26 RZR S 1000 4 March 27th, 2019 12:03 AM
Sturdy Rear Hitch Plow Mount BugBoyOne Projects and How-To 14 November 13th, 2017 12:42 PM
WTB: XP4 1k rear shock Melnik Want to Buy 0 March 31st, 2017 08:12 AM
Walker Evans rear shock lower mount replacement Kjansson Suspension 3 November 14th, 2016 09:08 AM
Broken rear A-Arm bolts ridinonfour RZR 900 - 50'' Trail Models 8 May 14th, 2016 03:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome