Clutch issues - Polaris RZR Forum - RZR Forums.net
RZR XP Turbo S Discuss the Polaris RZR XP Turbo S here!

 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old May 8th, 2019, 09:45 PM Thread Starter
 
Rzrhaulic's Avatar
 
Member #263882
Join Date: Dec 2018
Posts: 15
Feedback Score: 0 reviews
View Rzrhaulic's Photo Gallery(0)
Clutch issues

Dealer just replaced the primary clutch and rzr is now tough shifting between gears and when put into reverse the rzr jumps backwards or when put into high or low gear the rzr jumps forward. Is this normal?
Rzrhaulic is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old May 8th, 2019, 10:48 PM
 
FreeRider22's Avatar
 
Member #259668
Join Date: Aug 2018
Posts: 103
Feedback Score: 0 reviews
View FreeRider22's Photo Gallery(0)
Re: Clutch issues

Not sure if this is related to the primary being torqued to high or not but hard shifting was an issue many of us had with our new turbo s machines. What worked for myself and many others way to pull the primary off and reinstall it with proper torque spec. I canít remember off the top of my head what the spec was.


Sent from my iPhone using Tapatalk
FreeRider22 is offline  
post #3 of 18 Old May 9th, 2019, 09:19 AM
THD
 
THD's Avatar
 
First Name: Tim
My RZR: '19 T4 S
Member #27408
Join Date: Jun 2011
Location: Oregon
Posts: 553
Feedback Score: 1 reviews
View THD's Photo Gallery(1)
Re: Clutch issues

Quote:
Originally Posted by Rzrhaulic View Post
Dealer just replaced the primary clutch and rzr is now tough shifting between gears and when put into reverse the rzr jumps backwards or when put into high or low gear the rzr jumps forward. Is this normal?
Curious, why did the dealer replace the clutch?
THD is offline  
Sponsored Links
Advertisement
 
post #4 of 18 Old May 9th, 2019, 09:22 AM
 
ocrzrs's Avatar
 
Member #12451
Join Date: Jan 2010
Posts: 1,357
Feedback Score: 1 reviews
View ocrzrs's Photo Gallery(0)
Re: Clutch issues

Quote:
Originally Posted by Rzrhaulic View Post
Dealer just replaced the primary clutch and rzr is now tough shifting between gears and when put into reverse the rzr jumps backwards or when put into high or low gear the rzr jumps forward. Is this normal?
No this is not normal.
amthomas likes this.
ocrzrs is offline  
post #5 of 18 Old May 9th, 2019, 07:06 PM Thread Starter
 
Rzrhaulic's Avatar
 
Member #263882
Join Date: Dec 2018
Posts: 15
Feedback Score: 0 reviews
View Rzrhaulic's Photo Gallery(0)
Quote:
Originally Posted by THD View Post
Quote:
Originally Posted by Rzrhaulic View Post
Dealer just replaced the primary clutch and rzr is now tough shifting between gears and when put into reverse the rzr jumps backwards or when put into high or low gear the rzr jumps forward. Is this normal?
Curious, why did the dealer replace the clutch?
A piece of the guide broke off that the primary clutch moves on. Heard a like metal grinding noise so took the clutch cover off and started the rzr, with the rzr in park gave it a little gas and this small piece of like sheet metal cane flying out. Polaris said the primary clutch was on backorder till middle of May and rzr was fixed about a week ago. According to iron city polaris sent them a new clutch with a different part number.
Rzrhaulic is offline  
post #6 of 18 Old May 9th, 2019, 07:14 PM
 
Max H's Avatar
 
First Name: Max
My RZR: 2018 XTP 2 seat
Member #16311
Join Date: Jun 2010
Location: Idaho
Posts: 519
Garage
Feedback Score: 0 reviews
View Max H's Photo Gallery(0)
Re: Clutch issues

Hmm ...Keep us posted
Max H is offline  
post #7 of 18 Old May 9th, 2019, 11:10 PM
Premium Member
 
tw450's Avatar
 
Member #28947
Join Date: Aug 2011
Posts: 69
Feedback Score: 0 reviews
View tw450's Photo Gallery(0)
Re: Clutch issues

Quote:
Originally Posted by Rzrhaulic View Post
Quote:
Originally Posted by THD View Post
Quote:
Originally Posted by Rzrhaulic View Post
Dealer just replaced the primary clutch and rzr is now tough shifting between gears and when put into reverse the rzr jumps backwards or when put into high or low gear the rzr jumps forward. Is this normal?
Curious, why did the dealer replace the clutch?
A piece of the guide broke off that the primary clutch moves on. Heard a like metal grinding noise so took the clutch cover off and started the rzr, with the rzr in park gave it a little gas and this small piece of like sheet metal cane flying out. Polaris said the primary clutch was on backorder till middle of May and rzr was fixed about a week ago. According to iron city polaris sent them a new clutch with a different part number.
The sliders? My sliders broke and I found pieces attached to my magnetic weights on my aftermarket arms. Asked my dealer and he said he hadnít heard of any other problems with sliders breaking.
Max H likes this.
tw450 is offline  
post #8 of 18 Old May 10th, 2019, 01:19 PM Thread Starter
 
Rzrhaulic's Avatar
 
Member #263882
Join Date: Dec 2018
Posts: 15
Feedback Score: 0 reviews
View Rzrhaulic's Photo Gallery(0)
Quote:
Originally Posted by tw450 View Post
Quote:
Originally Posted by Rzrhaulic View Post
Quote:
Originally Posted by THD View Post

Curious, why did the dealer replace the clutch?
A piece of the guide broke off that the primary clutch moves on. Heard a like metal grinding noise so took the clutch cover off and started the rzr, with the rzr in park gave it a little gas and this small piece of like sheet metal cane flying out. Polaris said the primary clutch was on backorder till middle of May and rzr was fixed about a week ago. According to iron city polaris sent them a new clutch with a different part number.
The sliders? My sliders broke and I found pieces attached to my magnetic weights on my aftermarket arms. Asked my dealer and he said he hadnít heard of any other problems with sliders breaking.

Going to be taking back to the dealer will keep everyone posted on new info.
Rzrhaulic is offline  
post #9 of 18 Old May 11th, 2019, 08:40 AM Thread Starter
 
Rzrhaulic's Avatar
 
Member #263882
Join Date: Dec 2018
Posts: 15
Feedback Score: 0 reviews
View Rzrhaulic's Photo Gallery(0)
Well here is what happened after trying to take my rzr back. From the beginning Took my 2019 turbo s 4 rzr in about three weeks ago because I was hearing a clunking noise coming from the front end only while in 4x4. I could switch into 2x4 and the noise would go away and come back on 4x4. So iron city replaced the whole front diff and noise was gone. Got rzr home and noticed the front diff was leaking which looked like grease where the axel goes into the front diff on driver side. Wiped it off and waited to go on a ride to see if the grease came back. Ended upcoming wiping grease off three times and still coming back. Started the rzr after getting back home from shop and heard a funny noise now coming from the clutch, gave it a little gas in park and now the noise got worse sounding like metal grinding. Took the cover off, started the rzr gave it a little gas in park and a piece of metal came flying out of the clutch housing onto the ground. Took rzr back, iron city ended up replacing the primary clutch. Got rzr back and now it was making a loud like humming noise in park and neutral, noise would go away when put into gear. But when put into gear like reverse the rzr jumps back or if put into forward the rzr jumps forward. Dave the guy I was dealing with told me it was normal with a new clutch and to put 30 miles on it to break it in and all that would go away. This isnít my first rzr didnít think that was right so anyway took it on a 40 mile ride as suggested and still the same issues leaking front end and issues with clutch. Took rzr back to shop and Dave said there was nothing he could do about the front diff leaking because Polaris wouldnít pay him to investigate why it was leaking even though he just put the new diff in. So I asked if I should take rzr to different shop that was willing to fix a leaking front diff that was just put in. Dave said if I would have bought my rzr from him they would have had marge to investigate rzr without getting paid by Polaris to look at it. I asked Dave to put the rzr from park into reverse so I could get a video of the noise the clutch was making for my records. He threw a fit and told me to take the rzr to a different shop and that he would not help me. I do not recommend taking anything to iron city Polaris.
Highrider likes this.
Rzrhaulic is offline  
post #10 of 18 Old May 12th, 2019, 12:43 PM
 
DBRs1's Avatar
 
Member #257810
Join Date: Jul 2018
Posts: 440
Feedback Score: 0 reviews
View DBRs1's Photo Gallery(0)
Clutch issues are a real thing in the 2019 xpt and turbo s. A buddy of mine just bought a new velocity s and it spit the clutch cover bearing out and tossed it around the case with 13 miles on the odometer. Was only heat cycles in the yard with the tits still on the tires. Polaris had to replace everything. Belt case plastic cover, complete primary, complete secondary and belt. Here is a pic of the bearing it spit out from the aluminum clutch cover
Attached Thumbnails
Click image for larger version

Name:	78990_1557690157242.jpeg
Views:	61
Size:	87.0 KB
ID:	576936  
DBRs1 is offline  
post #11 of 18 Old May 12th, 2019, 10:04 PM
 
Riverguy553's Avatar
 
First Name: Scott
My RZR: 2019 Turbo 4S
Member #34623
Join Date: Jan 2012
Location: Chino Ca / Parker Az
Posts: 16
Feedback Score: 0 reviews
View Riverguy553's Photo Gallery(0)
This weekend I changed my clutch springs and weights as Iím running a 35Ē tire. Please know Iíve yet to use my RZR Turbo 4 S with 35Ē tires and Iím trying to stay ahead of the game. Upon taking everything apart I found on the secondary clutch 1 of 3 helix buttons were broke. Luckily the dealer had them so I replaced all 3. Then on my primary I found all 3 sliders broke, there was nothing I could for those as I didn‚Äôt have the tool to change them. I put it all back together and it seems to be fine for now. What do you think could be causing this? My car is also very hard to shift and itís been this way since day 1. When I had everything apart I reinstalled the primary and torqued it to proper specs. Car only has 350 miles on it.

Last edited by Riverguy553; May 12th, 2019 at 10:08 PM.
Riverguy553 is offline  
post #12 of 18 Old May 13th, 2019, 04:19 AM
 
turboedsupe's Avatar
 
Member #22257
Join Date: Jan 2011
Posts: 694
Feedback Score: 0 reviews
View turboedsupe's Photo Gallery(0)
Re: Clutch issues

Quote:
Originally Posted by Riverguy553 View Post
This weekend I changed my clutch springs and weights as Iím running a 35Ē tire. Please know Iíve yet to use my RZR Turbo 4 S with 35Ē tires and Iím trying to stay ahead of the game. Upon taking everything apart I found on the secondary clutch 1 of 3 helix buttons were broke. Luckily the dealer had them so I replaced all 3. Then on my primary I found all 3 sliders broke, there was nothing I could for those as I didn‚Äôt have the tool to change them. I put it all back together and it seems to be fine for now. What do you think could be causing this? My car is also very hard to shift and itís been this way since day 1. When I had everything apart I reinstalled the primary and torqued it to proper specs. Car only has 350 miles on it.
Why not just take it to the dealer and let them deal with it? Obviously something was not right from day 1 if it was hard to shift. Clutches need to be checked for alignment and made sure they seated correctly. Sucks to have clutch issues hopefully you get it figured out
turboedsupe is offline  
post #13 of 18 Old May 13th, 2019, 08:00 AM
 
Riverguy553's Avatar
 
First Name: Scott
My RZR: 2019 Turbo 4S
Member #34623
Join Date: Jan 2012
Location: Chino Ca / Parker Az
Posts: 16
Feedback Score: 0 reviews
View Riverguy553's Photo Gallery(0)
Re: Clutch issues

Quote:
Originally Posted by turboedsupe View Post
Quote:
Originally Posted by Riverguy553 View Post
This weekend I changed my clutch springs and weights as Iím running a 35Ē tire. Please know Iíve yet to use my RZR Turbo 4 S with 35Ē tires and Iím trying to stay ahead of the game. Upon taking everything apart I found on the secondary clutch 1 of 3 helix buttons were broke. Luckily the dealer had them so I replaced all 3. Then on my primary I found all 3 sliders broke, there was nothing I could for those as I didn‚Äôt have the tool to change them. I put it all back together and it seems to be fine for now. What do you think could be causing this? My car is also very hard to shift and itís been this way since day 1. When I had everything apart I reinstalled the primary and torqued it to proper specs. Car only has 350 miles on it.
Why not just take it to the dealer and let them deal with it? Obviously something was not right from day 1 if it was hard to shift. Clutches need to be checked for alignment and made sure they seated correctly. Sucks to have clutch issues hopefully you get it figured out
Iím sure now that Iíve messed with it the warranty is void? Iím going to call today and see what they say..
Attached Thumbnails
Click image for larger version

Name:	4247ADA5-C86A-4CB9-9280-45C21C4D92CD.jpeg
Views:	45
Size:	2.11 MB
ID:	576984   Click image for larger version

Name:	C3291E68-CDB0-451A-8943-DAD04253D684.jpeg
Views:	47
Size:	2.24 MB
ID:	576986   Click image for larger version

Name:	4496A9C0-2933-4DE8-AD69-6DD5FD76B637.jpeg
Views:	44
Size:	1.62 MB
ID:	576988  
Riverguy553 is offline  
post #14 of 18 Old May 13th, 2019, 08:10 AM
 
DBRs1's Avatar
 
Member #257810
Join Date: Jul 2018
Posts: 440
Feedback Score: 0 reviews
View DBRs1's Photo Gallery(0)
Is you aluminum primary clutch cover bearing still in place? This is the same thing that happened to my buddy's 19 velocity with 13 miles. It broke the plastic sliders in the primary after that bearing took a shit that rides on the spider. Then the pieces flying around in the case messed up parts in the secondary
Attached Thumbnails
Click image for larger version

Name:	78949_1557760185548.jpeg
Views:	45
Size:	36.9 KB
ID:	576990   Click image for larger version

Name:	78950_1557760204001.jpeg
Views:	48
Size:	52.5 KB
ID:	576992  
DBRs1 is offline  
post #15 of 18 Old May 13th, 2019, 08:49 AM
 
turboedsupe's Avatar
 
Member #22257
Join Date: Jan 2011
Posts: 694
Feedback Score: 0 reviews
View turboedsupe's Photo Gallery(0)
Re: Clutch issues

Quote:
Originally Posted by Riverguy553 View Post

Iím sure now that Iíve messed with it the warranty is void? Iím going to call today and see what they say..
I would put it all back together then just bring it in. Just play dumb and say you donít know whatís wrong with it
turboedsupe is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dalton clutch kit, my take Katnapper RZR 570 Specific Discussion 71 September 29th, 2018 07:07 AM
Clutch discussion, causes of heat/belt failures (long) cwarner Engine and Drivetrain 19 February 4th, 2018 10:36 AM
2011 xp 900 clutch issues Mills RZR XP 900 20 May 5th, 2017 11:18 PM
Clutch issues, need advice. Duner2 RZR XP 4 1000 43 December 16th, 2015 05:36 AM
UTVinc 60 AMP Alternator Kit Install Guide (RZR 800) MTW Projects and How-To 6 July 25th, 2015 10:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome