2011 900 XP - Pulls hard to the left - Polaris RZR Forum - RZR Forums.net
RZR XP 900 2011 to 2014 Polaris RZR XP 900 Forum on RZRForums.net

 
LinkBack Thread Tools Display Modes
post #1 of 10 Old June 18th, 2019, 10:49 AM Thread Starter
 
AwkDenver's Avatar
 
Member #270446
Join Date: Jun 2019
Posts: 5
Feedback Score: 0 reviews
View AwkDenver's Photo Gallery(0)
2011 900 XP - Pulls hard to the left

Hi Everyone,

I have a 2011 900 XP (no power steering) that pulls hard to the left and I cant figure out why. I have seen a few other posts where people have also had this problem and there were lots of suggestions but no definitive answer. I have tried most of the suggestions I have not had any success. When taking off from a stop the wheel immediately jerks to the left about a 1/4 turn. It takes a conscious effort and energy to keep the vehicle going strait, without it the wheel continues to turn left until the bike is in a full left turn. When moving at slow to moderate speeds it is very easy to steer to the left but takes more energy to steer to the right. Once at higher speeds it is less noticeable. There is no real noticeable difference between 2 and 4 wheel drive, however it does seem to be a little better with 4 wheel drive but still very noticeable.

Things I have tried that did not have an affect

  • Adjusted all 4 calipers to make sure they were not dragging
  • Checked all 4 wheel bearings to make sure they were not damaged
  • Replaced all 4 axles
  • Jacked up the front of the bike and made sure there was no play in the steering.
  • When jacked up both front tires spin about the same and I did not feel any drag.
  • Swapped the 2 front tires
  • Jacked up the back end of the bike and gave it some gas to make sure both back wheels were spinning.
  • Did an alignment. When I did the alignment I made sure that the steering wheel was strait and adjusted to that. In fact I actually adjusted it so the bike should pull to the right but it had no impact. The tie rods do not look bent or damaged any way, unless it is under the boot where I cant see it.
  • Checked to make sure all the bolts on the steering box were tight ( altho, now that I think about it I could double check where the box is bolted to the frame)
  • Checked for anything bent or out of shape and I do not see any kind of impact mark that would indicate significant damage
  • It seems to engage and disengage 4 wheel drive with out a problem.

I really appreciate any suggestions or pointers anyone has. I am really scratching my head on this one.

Thank you

Eric
AwkDenver is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old June 18th, 2019, 11:51 PM
 
ntrsandman's Avatar
 
First Name: Ken
My RZR: 2012 900 XP
Member #200753
Join Date: May 2017
Location: Galt, CA
Posts: 255
Feedback Score: 0 reviews
View ntrsandman's Photo Gallery(0)
Re: 2011 900 XP - Pulls hard to the left

Hi Eric and welcome to the forum!

Thanks for a detailed explanation on the concern and what you have done to try and correct the issue.

Reading what you have experienced, it is possible you have answered your own question. You stated that it is easier to steer left than right. I believe when you are moving forward, the force of the front tires on the ground will force the steering to go to the path of least resistance.

That said, I would disconnect the outer tie rods at the knuckles and check how the knuckles turn. Then check what I am suspecting. The steering gear/rack. If the steering wheel turns easier to the left than right, then I think you found the smoking gun.

Let us know what you find!

I'm just a soul whose intentions are good. Oh Lord, please don't let me be misunderstood.
ntrsandman is offline  
post #3 of 10 Old June 20th, 2019, 04:43 PM Thread Starter
 
AwkDenver's Avatar
 
Member #270446
Join Date: Jun 2019
Posts: 5
Feedback Score: 0 reviews
View AwkDenver's Photo Gallery(0)
Re: 2011 900 XP - Pulls hard to the left

Last night I jacked up the front of the machine and check for the amount of force needed to turn the wheels left and right. It was the same. One thing I did notice while looking around is that the driver side boot on the tie rod near the steering box looks like it has been replaced and a zip tie was used to keep it closed on the steering box side. It did not feel like there was anything majorly wrong inside by feeling it though the boot. But, it does seem that someone was in there at some point doing something. I bet that is where the problem is located
AwkDenver is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old June 21st, 2019, 07:25 PM
 
UPRIDER's Avatar
 
First Name: John
My RZR: 2012 Liquid Silver, 2014 Orange Madness
Member #47303
Join Date: Nov 2012
Location: Houghton Michigan
Posts: 229
Garage
Feedback Score: 0 reviews
View UPRIDER's Photo Gallery(0)
Re: 2011 900 XP - Pulls hard to the left

Did you swap rear tires , stand them next to each other and check heights?
UPRIDER is offline  
post #5 of 10 Old June 21st, 2019, 07:37 PM
 
Dirttracker13n's Avatar
 
First Name: Steve
My RZR: 1000 XP 4
Member #208609
Join Date: Jul 2017
Location: Mississippi
Posts: 28
Garage
Feedback Score: 0 reviews
View Dirttracker13n's Photo Gallery(0)
Re: 2011 900 XP - Pulls hard to the left

I am a service tech at the local Polaris dealer and we have ran into the racks going bad. Check the pinon on the rack where the steering rod couples to it. We have had a lot of the bearings going out right there.
Dirttracker13n is offline  
post #6 of 10 Old June 22nd, 2019, 07:44 AM Thread Starter
 
AwkDenver's Avatar
 
Member #270446
Join Date: Jun 2019
Posts: 5
Feedback Score: 0 reviews
View AwkDenver's Photo Gallery(0)
Re: 2011 900 XP - Pulls hard to the left

Quote:
Originally Posted by Dirttracker13n View Post
I am a service tech at the local Polaris dealer and we have ran into the racks going bad. Check the pinon on the rack where the steering rod couples to it. We have had a lot of the bearings going out right there.
Thank you! I will check it. I was just looking at the schematic for OEM parts and was unable to locate the bearing you mention. Any chance you have a part number for it?

Also, someone on Cragslist is selling the entire steering rack all the way down to the ball joints from a 2015 900 xp for 200$. When I look at the 2 schematics they look pretty much the same but different part numbers. Any chance that would fit on the 2011 900 xp?

Thanks again!
AwkDenver is offline  
post #7 of 10 Old June 22nd, 2019, 10:28 AM Thread Starter
 
AwkDenver's Avatar
 
Member #270446
Join Date: Jun 2019
Posts: 5
Feedback Score: 0 reviews
View AwkDenver's Photo Gallery(0)
Re: 2011 900 XP - Pulls hard to the left

Actually I just ordered a new aftermarket steering rack from Amazon. Hopefully it solves the problem
AwkDenver is offline  
post #8 of 10 Old June 22nd, 2019, 03:04 PM
 
dajo's Avatar
 
First Name: Dave
My RZR: 2010 RZR4 Street legal & 2011 XP 900(Arizona)2019 Honda Talon R
Member #19884
Join Date: Nov 2010
Location: Central Indiana & Baldwin, MI, Florence AZ
Posts: 404
Feedback Score: 0 reviews
View dajo's Photo Gallery(0)
Re: 2011 900 XP - Pulls hard to the left

Let us know how it works out.
dajo is offline  
post #9 of 10 Old June 22nd, 2019, 03:09 PM
 
shilo020's Avatar
 
First Name: Rick
My RZR: Wreck it Rick: 2015 XP1000 Voodoo Blue / You Know...For the Kids: 2015 XP1000 Havasu Red
Member #59828
Join Date: Aug 2013
Location: Redlands CA
Posts: 335
Feedback Score: 0 reviews
View shilo020's Photo Gallery(0)
Re: 2011 900 XP - Pulls hard to the left

It may not be front pulling left but rear pulling right. Check the rear alignment too. My car had a bent trailing arm. It was hard to see but enough that the car would not run straight.
shilo020 is offline  
post #10 of 10 Old July 8th, 2019, 11:51 AM Thread Starter
 
AwkDenver's Avatar
 
Member #270446
Join Date: Jun 2019
Posts: 5
Feedback Score: 0 reviews
View AwkDenver's Photo Gallery(0)
Re: 2011 900 XP - Pulls hard to the left

A new steering rack was 93$ on Amazon and I put that in and helped 75% of it. Then I checked the pressure on the rear passenger side and indeed it was low on pressure. That solve the problem like 90%. I figured the last 10% was from alignment, however I sold the bike before I got it totally fixed.

Thanks for the suggestions everyone!
AwkDenver is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome