Elec issues - Polaris RZR Forum - RZR Forums.net
RZR S 900 Discuss the 2015+ Polaris RZR S 900 vehicles here.

 1Likes
  • 1 Post By Impact344
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old June 23rd, 2019, 07:39 PM Thread Starter
 
Gigocatcher's Avatar
 
Member #270610
Join Date: Jun 2019
Posts: 1
Feedback Score: 0 reviews
View Gigocatcher's Photo Gallery(0)
Elec issues

Ok I suck at electrical I have speedo power when key is on but NO other power fuel pump or anything no start no lights there is a little blue led under dash that when it’s dim it’s having issues the battery was tested and good and 100 percent charged when jump cables hooked up after played with long enough all of a sudden the light under dash is bright and it will turn over also it was 100 percent fine until the stupid chain tensioner went out oh btw this is a 15 rzr 900 s I have since replaced the tensioner and have other problems other than the elec issues that’s another post
Gigocatcher is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old June 24th, 2019, 09:10 AM
Premium Member
 
Denver's Avatar
 
First Name: Denver
My RZR: 2015 S900 Titanium
Member #41951
Join Date: Jun 2012
Location: Northern Utah
Posts: 6,675
Garage
Feedback Score: 1 reviews
View Denver's Photo Gallery(4)
Re: Elec issues

Wow. Punctuation. Please. My eyes are bleeding just reading that.

Now, your electrical problem. I'd suspect loose battery cables, either at the battery (maybe some corrosion) or the negative cable attachment to the frame might be a bit loose and/or corroded.

The little blue light is just a courtesy lamp for night driving, in case you drop something.

SOLD!!! 2012 RZR 570, with most of the accessories.
Bought!!! 2015 RZR S900 Titanium! Let the fun begin (again)!!
XB3 fire extinguisher, in cab. RAM-mounted Samsung Tab GPS. Larsonator DIY dual rate spring kit and Schmidty Racing resi end caps. Garage Products bushings. BugBuster mesh windscreen and rear mesh screen. Outerwears on R2C air filter and clutch intake. 3500# Winch, parking brake. Polaris DVR mirror & Drift Innovation action camera. PRP harnesses. Roof. DIY mud flaps. Tusk front bumper. UHMW A-arm guards. Hunterworks Gates Carbon belt.
Denver is offline  
post #3 of 9 Old June 24th, 2019, 02:46 PM
 
slant911's Avatar
 
My RZR: 2019 XP Turbo
Member #269992
Join Date: Jun 2019
Location: USA
Posts: 27
Feedback Score: 0 reviews
View slant911's Photo Gallery(0)
Re: Elec issues

My bet is a bad ground. Make sure all grounds are tight and corrosion free.
slant911 is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old June 24th, 2019, 06:46 PM
 
Impact344's Avatar
 
Member #268904
Join Date: Apr 2019
Posts: 95
Feedback Score: 0 reviews
View Impact344's Photo Gallery(0)
Quote:
Originally Posted by Gigocatcher View Post
Ok I suck at electrical I have speedo power when key is on but NO other power fuel pump or anything no start no lights there is a little blue led under dash that when it’s dim it’s having issues the battery was tested and good and 100 percent charged when jump cables hooked up after played with long enough all of a sudden the light under dash is bright and it will turn over also it was 100 percent fine until the stupid chain tensioner went out oh btw this is a 15 rzr 900 s I have since replaced the tensioner and have other problems other than the elec issues that’s another post
yea check all your battery connections and it sounds like you and I need to attend the "Denver school of fine English" he gave me the same punctuation non sense he gave you but idk any better I'm from west virginia
Denver likes this.
Impact344 is offline  
post #5 of 9 Old June 24th, 2019, 11:03 PM
Premium Member
 
Denver's Avatar
 
First Name: Denver
My RZR: 2015 S900 Titanium
Member #41951
Join Date: Jun 2012
Location: Northern Utah
Posts: 6,675
Garage
Feedback Score: 1 reviews
View Denver's Photo Gallery(4)
Re: Elec issues

Quote:
Originally Posted by Impact344 View Post
yea check all your battery connections and it sounds like you and I need to attend the "Denver school of fine English" he gave me the same punctuation non sense he gave you but idk any better I'm from west virginia
Hey, at least you can use quotation marks properly! (And I'm from PA, just north of Morgantown.)

SOLD!!! 2012 RZR 570, with most of the accessories.
Bought!!! 2015 RZR S900 Titanium! Let the fun begin (again)!!
XB3 fire extinguisher, in cab. RAM-mounted Samsung Tab GPS. Larsonator DIY dual rate spring kit and Schmidty Racing resi end caps. Garage Products bushings. BugBuster mesh windscreen and rear mesh screen. Outerwears on R2C air filter and clutch intake. 3500# Winch, parking brake. Polaris DVR mirror & Drift Innovation action camera. PRP harnesses. Roof. DIY mud flaps. Tusk front bumper. UHMW A-arm guards. Hunterworks Gates Carbon belt.
Denver is offline  
post #6 of 9 Old June 25th, 2019, 04:11 AM
 
Impact344's Avatar
 
Member #268904
Join Date: Apr 2019
Posts: 95
Feedback Score: 0 reviews
View Impact344's Photo Gallery(0)
Quote:
Originally Posted by Denver View Post
Quote:
Originally Posted by Impact344 View Post
yea check all your battery connections and it sounds like you and I need to attend the "Denver school of fine English" he gave me the same punctuation non sense he gave you but idk any better I'm from west virginia
Hey, at least you can use quotation marks properly! (And I'm from PA, just north of Morgantown.)
[IMG class=inlineimg]https://www.rzrforums.net/images/rzrforums_toucan/smilies/tango_face_grin.png[/IMG][IMG class=inlineimg]https://www.rzrforums.net/images/rzrforums_toucan/smilies/tango_face_devil.png[/IMG][IMG class=inlineimg]https://www.rzrforums.net/images/rzrforums_toucan/smilies/tango_face_grin.png[/IMG]
lol and do you know much about solemen chevy in masontown pa? I am going to look at a 3/4ton chevy today
Impact344 is offline  
post #7 of 9 Old June 26th, 2019, 08:23 AM
Premium Member
 
Denver's Avatar
 
First Name: Denver
My RZR: 2015 S900 Titanium
Member #41951
Join Date: Jun 2012
Location: Northern Utah
Posts: 6,675
Garage
Feedback Score: 1 reviews
View Denver's Photo Gallery(4)
Re: Elec issues

Quote:
Originally Posted by Impact344 View Post
lol and do you know much about solemen chevy in masontown pa? I am going to look at a 3/4ton chevy today
Not a clue. Left there when I joined the military (1974) and only occasionally visited since then. Sorry,,,

SOLD!!! 2012 RZR 570, with most of the accessories.
Bought!!! 2015 RZR S900 Titanium! Let the fun begin (again)!!
XB3 fire extinguisher, in cab. RAM-mounted Samsung Tab GPS. Larsonator DIY dual rate spring kit and Schmidty Racing resi end caps. Garage Products bushings. BugBuster mesh windscreen and rear mesh screen. Outerwears on R2C air filter and clutch intake. 3500# Winch, parking brake. Polaris DVR mirror & Drift Innovation action camera. PRP harnesses. Roof. DIY mud flaps. Tusk front bumper. UHMW A-arm guards. Hunterworks Gates Carbon belt.
Denver is offline  
post #8 of 9 Old June 26th, 2019, 08:24 AM
Premium Member
 
Denver's Avatar
 
First Name: Denver
My RZR: 2015 S900 Titanium
Member #41951
Join Date: Jun 2012
Location: Northern Utah
Posts: 6,675
Garage
Feedback Score: 1 reviews
View Denver's Photo Gallery(4)
Re: Elec issues

Quote:
Originally Posted by Gigocatcher View Post
Ok I suck at electrical I have speedo power when key is on but NO other power fuel pump or anything no start no lights there is a little blue led under dash that when itís dim itís having issues the battery was tested and good and 100 percent charged when jump cables hooked up after played with long enough all of a sudden the light under dash is bright and it will turn over also it was 100 percent fine until the stupid chain tensioner went out oh btw this is a 15 rzr 900 s I have since replaced the tensioner and have other problems other than the elec issues thatís another post
Back on the OP (original poster), sorry for hijacking your thread. Have you found any answer to your problem? Please let us know.

SOLD!!! 2012 RZR 570, with most of the accessories.
Bought!!! 2015 RZR S900 Titanium! Let the fun begin (again)!!
XB3 fire extinguisher, in cab. RAM-mounted Samsung Tab GPS. Larsonator DIY dual rate spring kit and Schmidty Racing resi end caps. Garage Products bushings. BugBuster mesh windscreen and rear mesh screen. Outerwears on R2C air filter and clutch intake. 3500# Winch, parking brake. Polaris DVR mirror & Drift Innovation action camera. PRP harnesses. Roof. DIY mud flaps. Tusk front bumper. UHMW A-arm guards. Hunterworks Gates Carbon belt.
Denver is offline  
post #9 of 9 Old June 27th, 2019, 06:17 AM
 
Threewheel79's Avatar
 
Member #164161
Join Date: Oct 2016
Posts: 4
Feedback Score: 0 reviews
View Threewheel79's Photo Gallery(0)
I'm having the same exact electrical issue on a 2016 900s. Any luck?
Threewheel79 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome