Clock keeps blinking 12:00. 2019 XP4 1000 Turbo - Polaris RZR Forum - RZR Forums.net
Lighting, Stereo and Electrical For discussion of lighting, stereo and other electrical components

Forum sponsored by: Rockford Fosgate

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old May 27th, 2019, 10:20 AM Thread Starter
 
Kzneft's Avatar
 
My RZR: 2019 RZR4 Turbo
Member #68959
Join Date: May 2014
Location: Utah
Posts: 50
Feedback Score: 0 reviews
View Kzneft's Photo Gallery(4)
Clock keeps blinking 12:00. 2019 XP4 1000 Turbo

My 2019 RZR4 1000 turbo is only a few months old. I have reset the clock about a dozen times now, but as soon as I turn my RZR off, then back on it keeps blinking the 12:00 symbol again. It keeps time good as long as it's running, but not after turning off. Followed the instructions numerous times but no luck. Dealer has no answer either. Anyone else seen this?
Kzneft is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old May 27th, 2019, 12:49 PM
 
yetifed's Avatar
 
First Name: Hall
My RZR: 2017 XP 4 Turbo
Member #51910
Join Date: Feb 2013
Location: Germantown,TN
Posts: 142
Garage
Feedback Score: 0 reviews
View yetifed's Photo Gallery(0)
Re: Clock keeps blinking 12:00. 2019 XP4 1000 Turbo

I had the exact same issue, shockingly enough I disconnected both battery leads for a few minutes and that solved the issue. sounds to simple to be true but it worked. I even posted a video on here of mine doing it, I had the battery disconnect by accident while working on something else and when it was reconnected, no more issues.
Hope this helps.
yetifed is offline  
post #3 of 8 Old May 27th, 2019, 05:26 PM Thread Starter
 
Kzneft's Avatar
 
My RZR: 2019 RZR4 Turbo
Member #68959
Join Date: May 2014
Location: Utah
Posts: 50
Feedback Score: 0 reviews
View Kzneft's Photo Gallery(4)
Re: Clock keeps blinking 12:00. 2019 XP4 1000 Turbo

I will go try that right now! I will let you know the outcome.
Kzneft is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old May 27th, 2019, 05:50 PM Thread Starter
 
Kzneft's Avatar
 
My RZR: 2019 RZR4 Turbo
Member #68959
Join Date: May 2014
Location: Utah
Posts: 50
Feedback Score: 0 reviews
View Kzneft's Photo Gallery(4)
Re: Clock keeps blinking 12:00. 2019 XP4 1000 Turbo

Just tried it, but unfortunately that didn't work on mine.
Kzneft is offline  
post #5 of 8 Old May 27th, 2019, 06:08 PM Thread Starter
 
Kzneft's Avatar
 
My RZR: 2019 RZR4 Turbo
Member #68959
Join Date: May 2014
Location: Utah
Posts: 50
Feedback Score: 0 reviews
View Kzneft's Photo Gallery(4)
Re: Clock keeps blinking 12:00. 2019 XP4 1000 Turbo

I have disconnected the battery, and will let sit overnight, and try again. Another thing I am wondering. If you scroll down to where you see it say VOLTS on your screen, does yours say 0 volts? Mine says 0 volts whether it is running or not. Does your do the same thing? I am wondering if this is related to the clock issue. I have attached a picture.
Attached Thumbnails
Click image for larger version

Name:	IMG_0646.jpg
Views:	18
Size:	85.3 KB
ID:	577674  
Kzneft is offline  
post #6 of 8 Old May 28th, 2019, 05:51 AM
Aspiring Perfectionist
 
RWB713's Avatar
 
First Name: Richard
My RZR: 2018 XP4 Turbo
Member #70552
Join Date: Jul 2014
Location: Aztec, NM
Posts: 1,297
Garage
Feedback Score: 3 reviews
View RWB713's Photo Gallery(0)
Re: Clock keeps blinking 12:00. 2019 XP4 1000 Turbo

Try unplugging and plugging back in the display.

On my 18, the clock worked fine until I unhooked the dash to do some wiring, then when i got everything back together, my clock was doing the same thing yours is, I just wrote it off as I'd need to change the whole display to fix it, which wasn't worth it to me, it was that way for about 5 months. Low and behold, I unhooked everything again a few weeks ago, and when i plugged it all back in, the clock works like normal now. Could just be a stubborn pin in that plug I think. My voltmeter always worked fine, but could very well be a similar issue.

"I strive for a level of perfection I don't possess the skillset to achieve"
2018 XPT4 - Bailey

Help me get some info in these threads: Tire Height --- Front Diff
RWB713 is online now  
post #7 of 8 Old May 28th, 2019, 05:59 AM Thread Starter
 
Kzneft's Avatar
 
My RZR: 2019 RZR4 Turbo
Member #68959
Join Date: May 2014
Location: Utah
Posts: 50
Feedback Score: 0 reviews
View Kzneft's Photo Gallery(4)
Re: Clock keeps blinking 12:00. 2019 XP4 1000 Turbo

I will give that a try this afternoon. Thank you!
Kzneft is offline  
post #8 of 8 Old May 28th, 2019, 03:45 PM
 
Oldbiker's Avatar
 
First Name: Mike
My RZR: 2017 900 S
Member #69733
Join Date: Jun 2014
Location: Western Colorado
Posts: 117
Feedback Score: 0 reviews
View Oldbiker's Photo Gallery(0)
Re: Clock keeps blinking 12:00. 2019 XP4 1000 Turbo

I've always been told to start by checking all the ground wire connections - one that is loose or corroded will act differently when the machine is vibrating than when its not running.

2017 900 S - 28x10 Sedona Rock-A-Billys on 14x7 wheels.
Oldbiker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome