Power steering issue after light bar install - Polaris RZR Forum - RZR Forums.net
Lighting, Stereo and Electrical For discussion of lighting, stereo and other electrical components

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old October 10th, 2016, 02:51 PM Thread Starter
 
enigma94's Avatar
 
Member #147721
Join Date: Jul 2016
Location: AZ
Posts: 68
Feedback Score: 0 reviews
View enigma94's Photo Gallery(0)
Power steering issue after light bar install

Me and my brother just installed our light bars on our 16 XPT's and now we have intermittent issues with power steering not working right when we turn the cart on. If we turn the cart off then back on the power steering starts working... His is doing it more than mine but both are having issues.

We ran 10ga power 14ga ground from the battery to the terminal on the firewall. Installed our hot and ground leads from our relay to the same post and then installed a wire from the switch to the accessory terminal to light up the switch when not in use.

Is there something wrong with how we wired them that's causing the power steering to not work right at start up???
enigma94 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old October 10th, 2016, 08:14 PM
 
claas's Avatar
 
Member #85471
Join Date: Oct 2015
Posts: 151
Feedback Score: 0 reviews
View claas's Photo Gallery(0)
Re: Power steering issue after light bar install

If you take the wires off for the lightbar does the power steering function properly then and it's only when you hook your wiring up? Wiring sounds like it was ran fine


Sent from my iPhone using Tapatalk
claas is offline  
post #3 of 7 Old October 11th, 2016, 12:52 AM
 
Jjwheeler2's Avatar
 
Member #138641
Join Date: Jun 2016
Posts: 103
Feedback Score: 0 reviews
View Jjwheeler2's Photo Gallery(0)
Re: Power steering issue after light bar install

Only issue I see is you should have run same size ground as you did power.
Even that though shouldn't be messing with the power steering.
Jjwheeler2 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old October 11th, 2016, 07:05 AM
 
Weerdone's Avatar
 
First Name: Steve
My RZR: 2019 RZR XPT
Member #127465
Join Date: May 2016
Location: Iowa
Posts: 220
Garage
Feedback Score: 0 reviews
View Weerdone's Photo Gallery(0)
Re: Power steering issue after light bar install

I know after the ignition is turned on, if you wait too long to start it will disable the Power steering. Take notice if the problem is mainly after sitting with key on looking at lights, or listening to radio. My 16' after i sit with key on to keep lights lit up it will shut off the power steering, then i need to cycle key off and back on and it works fine.
Weerdone is offline  
post #5 of 7 Old October 11th, 2016, 08:54 AM
 
DogRunner2's Avatar
 
Member #137545
Join Date: Jun 2016
Posts: 952
Garage
Feedback Score: 0 reviews
View DogRunner2's Photo Gallery(0)
Re: Power steering issue after light bar install

Quote:
Originally Posted by Weerdone View Post
I know after the ignition is turned on, if you wait too long to start it will disable the Power steering. Take notice if the problem is mainly after sitting with key on looking at lights, or listening to radio. My 16' after i sit with key on to keep lights lit up it will shut off the power steering, then i need to cycle key off and back on and it works fine.
Yep. It's in the manual.

2018 XP1K LE
DogRunner2 is offline  
post #6 of 7 Old October 11th, 2016, 02:52 PM
 
RIPPED_RZR's Avatar
 
Member #137985
Join Date: Jun 2016
Posts: 2
Feedback Score: 0 reviews
View RIPPED_RZR's Photo Gallery(0)
I turn the key and let it prime and then turn it on. It happened to me twice on Sunday. Never happened before we installed the light bar. It's happened on cold starts and warm starts.
RIPPED_RZR is offline  
post #7 of 7 Old October 11th, 2016, 02:53 PM
 
RIPPED_RZR's Avatar
 
Member #137985
Join Date: Jun 2016
Posts: 2
Feedback Score: 0 reviews
View RIPPED_RZR's Photo Gallery(0)
I'm enigmas brother by the way lol
RIPPED_RZR is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
LED light bar whistle Scott M General RZR Discussion 10 October 3rd, 2016 09:39 AM
XP 900 power steering install question Longrange223 RZR XP 900 4 May 12th, 2016 05:09 AM
2012 800 Power Steering Issue Chris073 RZR 800 Specific Discussion 1 April 7th, 2016 01:15 PM
Power steering startup issue MLESa7990 RZR 900 - 50'' Trail Models 7 April 2nd, 2016 11:31 AM
OV 17.6 - Power Steering and Check Engine light RZR 1000 RZR_BC RZR XP 1000 3 March 21st, 2016 06:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome