08 rzr issues - Polaris RZR Forum - RZR Forums.net
General RZR Discussion For General Polaris RZR discussion.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 Old May 30th, 2012, 08:16 PM Thread Starter
 
4strokejunkie's Avatar
 
Member #28580
Join Date: Jul 2011
Posts: 32
Feedback Score: 0 reviews
View 4strokejunkie's Photo Gallery(0)
08 rzr issues

Hey guys i went to a derby a few weeks ago and my rzr starting acting up,it will not idle anymore unless you give it gas.So i finally got time to look at it and found the plugs to be really black so im guessing one is fouled and i will replace both.Now i also found the boot between airbox and throttle body had come off throttle body and is really dirty inside.Im gona clean everything but was wondering what kinda damage the dust would have done.I will do a compression test tomorow to see if its ok.Anyone ever have that boot come off ?...thxs
4strokejunkie is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old May 31st, 2012, 01:02 AM
glamisdunes*****
 
dev's rzr's Avatar
 
First Name: devin
My RZR: 08 rzr
Member #5605
Join Date: Dec 2008
Location: glendora
Posts: 3,646
Feedback Score: 2 reviews
View dev's rzr's Photo Gallery(2) Send a message via AIM to dev's rzr
Re: 08 rzr issues

not good for the motor i had a freind had that happen and he had to get the motor rebuilt check yr air box and the sensor

[/SIGPIC]
dev's rzr is offline  
post #3 of 17 Old May 31st, 2012, 05:13 AM Thread Starter
 
4strokejunkie's Avatar
 
Member #28580
Join Date: Jul 2011
Posts: 32
Feedback Score: 0 reviews
View 4strokejunkie's Photo Gallery(0)
Re: 08 rzr issues

My compression is 135 & 120 psi,looks like it needs a top end..this is not good for a rzr with just over a 1000 miles...
4strokejunkie is offline  
Sponsored Links
Advertisement
 
post #4 of 17 Old May 31st, 2012, 05:40 AM
 
swingarm1's Avatar
 
First Name: Tim
My RZR: TAGTEAM APEX / UTVINC / COGNITO / STM / HOLZ / GNS / $$$$ EDITION
Member #7690
Join Date: May 2009
Location: PRESCOTT, ARIZONA (928) 273-4249
Posts: 41,101
Feedback Score: 176 reviews
View swingarm1's Photo Gallery(1)
Re: 08 rzr issues

Quote:
Originally Posted by 4strokejunkie View Post
My compression is 135 & 120 psi,looks like it needs a top end..this is not good for a rzr with just over a 1000 miles...
Pistons, cylinder (honed if yours is not damaged), head gasket, base gasket and valve job at the least...


I have these kits in stock ready to ship, this takes the guessing and time wasted waiting for your dealer to order the parts...These are OEM Polaris Parts for the RZR, RZR S and RZR 4 "800" Engines...


1) Head Gasket (1) $30.00
2) Base Gasket (1) $20.00
3) Mag / Access Gasket (1) $18.00
4) Oil / Water Pump (1) $115.00
5) Oil Pickup Tube (1) $22.00
6) Oil Shaft Seal (1) $28.00
7) Seal (1) $21.00
8) Seal (1) $13.00
9) Water Pump Seal (1) $40.00
10) Main Bearings (2) $40.00
11) Counter Balancer Bearings (4) $75.00
12) Pistons, Rings Wrist Pins and Cir-Clips (2 sets) $199.00
13) Oil (2 qts) $20.00
14) Oil Filter (1) $10.00
15) Dowel Pin (1) $5.00
16) Spring (1) $5.00
17) Spark Plugs (2) $12.00
18) Lifters (4) $40.00
19) Push Rods (4) $88.00
20) Cylinder (1) $300.00
21) Crank (1) Cost Depends on OEM or Aftermarket
22) Valve Job (Cost Depends on Parts required)
23) UTVINC Billet Breather (1) $39.95

Pick and choose your parts...

Total Of Parts PLUS Shipping to the lower 48 States... [/quote]
swingarm1 is offline  
post #5 of 17 Old May 31st, 2012, 05:55 AM Thread Starter
 
4strokejunkie's Avatar
 
Member #28580
Join Date: Jul 2011
Posts: 32
Feedback Score: 0 reviews
View 4strokejunkie's Photo Gallery(0)
Are there aftermarket pistons and rings i can use or do most use the polaris,as far as valves i should be able to grind them if they arent to bad,..thxs guys

Sent from my BlackBerry 9800 using Tapatalk
4strokejunkie is offline  
post #6 of 17 Old May 31st, 2012, 06:02 AM
 
swingarm1's Avatar
 
First Name: Tim
My RZR: TAGTEAM APEX / UTVINC / COGNITO / STM / HOLZ / GNS / $$$$ EDITION
Member #7690
Join Date: May 2009
Location: PRESCOTT, ARIZONA (928) 273-4249
Posts: 41,101
Feedback Score: 176 reviews
View swingarm1's Photo Gallery(1)
Re: 08 rzr issues

Quote:
Originally Posted by 4strokejunkie View Post
Are there aftermarket pistons and rings i can use or do most use the polaris,as far as valves i should be able to grind them if they arent to bad,..thxs guys

Yes on the valves, CP and JE both make forged pistons for the RZR...
swingarm1 is offline  
post #7 of 17 Old May 31st, 2012, 06:16 AM
 
Pirate's Avatar
 
First Name: Stuart
My RZR: 2009 Nuclear Sunset special edition
Member #3677
Join Date: Aug 2008
Location: Canon City, Colorado
Posts: 7,239
Feedback Score: 3 reviews
View Pirate's Photo Gallery(0)
Re: 08 rzr issues

Check the throttle body and intake tracks to see if they are covered with a "mud" of gas and dust. If yes, then without a doubt its time for a top end.

BUT, drain the oil, did you get about two quarts? Is it really dirty? If you strain it through a rag are there metal particles present? If yes to any of these, there may be more damage than just the top end. Yup...had this happen!!

Think about getting a $300 4UCam 3 ft video probe. Then you can inspect all the boot connections before and after every ride. It will take pictures or video, but you can simply watch the screen and see how things look.

This is a critical part of my ride prep....don't want another trashed engine!!!

Pirate
Pirate is offline  
post #8 of 17 Old May 31st, 2012, 06:44 AM
 
whaffner's Avatar
 
First Name: Wayne
My RZR: 2016 trail 900 eps
Member #16284
Join Date: Jun 2010
Location: Jerome, ID
Posts: 1,654
Garage
Feedback Score: 5 reviews
View whaffner's Photo Gallery(0)
Re: 08 rzr issues

i'm surprised polaris doesnt include on board engine video analysis for the motor.
whaffner is offline  
post #9 of 17 Old May 31st, 2012, 01:46 PM
 
Pirate's Avatar
 
First Name: Stuart
My RZR: 2009 Nuclear Sunset special edition
Member #3677
Join Date: Aug 2008
Location: Canon City, Colorado
Posts: 7,239
Feedback Score: 3 reviews
View Pirate's Photo Gallery(0)
Re: 08 rzr issues

ppppfffftttt...you think Polaris is going to do that for us or their Dealers???? ROTFLMAO

Pirate
Pirate is offline  
post #10 of 17 Old May 31st, 2012, 02:55 PM
 
whaffner's Avatar
 
First Name: Wayne
My RZR: 2016 trail 900 eps
Member #16284
Join Date: Jun 2010
Location: Jerome, ID
Posts: 1,654
Garage
Feedback Score: 5 reviews
View whaffner's Photo Gallery(0)
Re: 08 rzr issues

Sounds like you would buy one?
whaffner is offline  
post #11 of 17 Old May 31st, 2012, 05:12 PM
 
Pirate's Avatar
 
First Name: Stuart
My RZR: 2009 Nuclear Sunset special edition
Member #3677
Join Date: Aug 2008
Location: Canon City, Colorado
Posts: 7,239
Feedback Score: 3 reviews
View Pirate's Photo Gallery(0)
Re: 08 rzr issues

Yup, I'm having a ball with my four year old RZR. If someone came out with a plug in monitor for the RZR systems...I would be first in line to buy one.

The video probe...yup got one. Use it after every ride to inspect and make sure all is well under the bed. I often prop the gas pedal down and inspect the intake tract all the way to the intake valve.

After trashing a Holz motor, I'm do a pretty thorough check of things after every ride.

I've also got Dakota Digital Volts, Water Temp and Oil Pressure to help me keep an eye on that data. I like the Dakota Digital because they are digital and very accurate.

Pirate
Pirate is offline  
post #12 of 17 Old May 31st, 2012, 11:12 PM
Family, it's about time
 
Familyman's Avatar
 
First Name: Paul
My RZR: 2012 xp4 900
Member #10232
Join Date: Oct 2009
Location: Mesa, Az
Posts: 1,503
Feedback Score: 0 reviews
View Familyman's Photo Gallery(6)
Re: 08 rzr issues

You need a top end for sure. When you are all done you need to throw out your stock air box and buy a Donaldson from vent racing, a ump, or the UTV inc filter setup. Any of those three a great setups. The problem with the factory one is it mounts to the frame and when the engine moves around the boot will work loose. The three setups I mentioned all mount to the transmission and move with the engine so no more boots popping loose.
Familyman is offline  
post #13 of 17 Old May 31st, 2012, 11:21 PM
King of crash!
 
johnnycat8's Avatar
 
First Name: john
My RZR: 2nd gen...red
Member #787
Join Date: Dec 2007
Location: roseville calif.
Posts: 31,883
Garage
Feedback Score: 9 reviews
View johnnycat8's Photo Gallery(0) Send a message via Yahoo to johnnycat8
Re: 08 rzr issues

They make a new boot that flexes more get that also

link for crow dog's site!!! www.utvguide.net


running makin trax afco shocks and springs
johnnycat8 is offline  
post #14 of 17 Old June 1st, 2012, 06:41 AM
 
Pirate's Avatar
 
First Name: Stuart
My RZR: 2009 Nuclear Sunset special edition
Member #3677
Join Date: Aug 2008
Location: Canon City, Colorado
Posts: 7,239
Feedback Score: 3 reviews
View Pirate's Photo Gallery(0)
Re: 08 rzr issues

Johnnycat,

Who make the new boot that flexes?

Familyman,

The Vent Racing system, using a Donaldson filter system, also mounts to the frame. But, the intake boot I have has a bellows in it that allows it to flex. While installing it, with the bed off, I put the boot over the canister outlet and shoved it as far as I could towards the throttle body. I replaced the clamps on both ends of the boot. I made sure the boot was on to the throttle body as far as possible then clamped it tight. Then did the same at the canister end. The Vent Racing system comes with a clamp around the canister body, so the canister can be moved to the right.

Here are some pics of my Vent Racing install:







Here is info on the heat shield I used on the canister. Attached it using good 'ol 100mph aluminum tape.



As you can see there is a brass threaded insert in the Canister neck. I used a brass Tee and attached the valve cover breather hose and a filter minder to let me know when the filter is becoming restricted. Just like my diesel pickup very handy. As you can see I mounted it between the seats so I can see it in my rear view mirror.





Lemme know if you have questions.

Pirate
Pirate is offline  
post #15 of 17 Old June 3rd, 2012, 10:11 AM Thread Starter
 
4strokejunkie's Avatar
 
Member #28580
Join Date: Jul 2011
Posts: 32
Feedback Score: 0 reviews
View 4strokejunkie's Photo Gallery(0)
Well its apart and not to bad,new rings,gaskets and a good cleanin.I was wondering what the better plug to use is.it had champion and i switched to nkg last time...thxs


Sent from my BlackBerry 9800 using Tapatalk
4strokejunkie is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rzr issues Jmccart Engine and Drivetrain 2 November 25th, 2011 07:54 PM
Rzr 800 bog issues Jmccart Engine and Drivetrain 14 November 23rd, 2011 05:17 PM
issues BOOYAH RZR 170 Specific Disccusion 7 December 22nd, 2010 10:42 AM
What issues will I have? Swamp Fox General RZR Discussion 15 December 9th, 2009 06:11 AM
08 RZR issues grtrnd1 Engine and Drivetrain 1 June 28th, 2009 08:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome