Need help - Polaris RZR Forum - RZR Forums.net
General RZR Discussion For General Polaris RZR discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old May 29th, 2012, 08:03 AM Thread Starter
 
cribbs13's Avatar
 
First Name: Kyle
My RZR: 2011 RZR 4
Member #18128
Join Date: Aug 2010
Posts: 313
Feedback Score: 0 reviews
View cribbs13's Photo Gallery(0)
Angry Need help

Has anyone had this happen to them? I was riding down a trail last saturday and hit a hard rut doing about 20. My front tire now sits out like I am taking a left turn when my right tire is straight. I was looking at my suspenion and it seems to be all fine but my knuckle seems to be bent. I have not taken compared it to a none bent knuckle except for my passenger side on, and it seems to be bent where my steering rod connects. It just seems weird to me that such a large piece of metal wold bend and nothing else. Please help bc I dont want to buy it if there is a diffrent problem.
cribbs13 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old May 29th, 2012, 08:24 AM
 
Tuf-Skin's Avatar
 
First Name: Clifford
My RZR: 2014 XP-1000 & 2015 XP-1000
Member #2228
Join Date: Apr 2008
Location: Live in Eugene, OR; Work in Junction City, OR; Ride the dunes near Florence, OR
Posts: 15,386
Feedback Score: 7 reviews
View Tuf-Skin's Photo Gallery(7)
Re: Need help

The bearing carrier?
Isn't it cast? It should break not bend.
Sure it isn't a bent tie rod or broken ball joint?
Tuf-Skin is offline  
post #3 of 4 Old May 29th, 2012, 09:21 AM Thread Starter
 
cribbs13's Avatar
 
First Name: Kyle
My RZR: 2011 RZR 4
Member #18128
Join Date: Aug 2010
Posts: 313
Feedback Score: 0 reviews
View cribbs13's Photo Gallery(0)
Re: Need help

Quote:
Originally Posted by Tuf-Skin View Post
The bearing carrier?
Isn't it cast? It should break not bend.
Sure it isn't a bent tie rod or broken ball joint?
Yes it is the cast piece I have not removed that yet but i am going to do that when I get home today. My uper and lower arms are fine my tie rod is fine, I guess it could be a broken ball joint. Is the ball joint what mounts axle to hub?
cribbs13 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old May 29th, 2012, 09:34 AM
 
Pirate's Avatar
 
First Name: Stuart
My RZR: 2009 Nuclear Sunset special edition
Member #3677
Join Date: Aug 2008
Location: Canon City, Colorado
Posts: 7,239
Feedback Score: 3 reviews
View Pirate's Photo Gallery(0)
Re: Need help

I would bet you banged the alignment out, which means you probably bent a tie rod.

Which would account for the alignment being way off.

Pirate
Pirate is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome