Low idle when it got hot??? - Polaris RZR Forum - RZR Forums.net
General RZR Discussion For General Polaris RZR discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old May 27th, 2012, 08:44 AM Thread Starter
 
psychorzr's Avatar
 
Member #35340
Join Date: Jan 2012
Location: waynesville MO.
Posts: 107
Feedback Score: 0 reviews
View psychorzr's Photo Gallery(0)
Low idle when it got hot???

Took my 09 RZR S to SMORR yesterday...one of the most dusty places ive ever been!!! Now before the trip i cleaned my K&N air filter within an inch of its life..and really it wasnt that dirty..the outerwear was dirty but when i flushed the filert its self it was suprisenly clean...anyway, it started the day off at its usual 1100-1150/60 RPM at idle.....as the day went on and it got hotter i noticed a lil sputter at low speed and reverse, but absoutly no power loss when on the throttle. At mid day and very warm outside (and dusty) i noticed the RPM's at 1000-940/30....would go back up to 1000-1050 when the fan came on......towards the end of the day i seen it dip into the 700-800 a few times...still with no loss of power. I checked the filter when i got home that evening......the outer wear was pretty dusty and the airbox has fine dust in it..but the filter and as far as i could tell the intake was clean. went out to wash the RZR this morn and the idle was still at 900-950...anyone wanna guess why? It is all stock except for a Dynatec fuel programmer that was on it when i bought it.
psychorzr is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old May 27th, 2012, 05:51 PM Thread Starter
 
psychorzr's Avatar
 
Member #35340
Join Date: Jan 2012
Location: waynesville MO.
Posts: 107
Feedback Score: 0 reviews
View psychorzr's Photo Gallery(0)
Re: Low idle when it got hot???

anyone? anyone?........after a good washing the idle speed is back up to 1040-1060 range.
psychorzr is offline  
post #3 of 3 Old May 28th, 2012, 07:33 AM
 
insaneclowns04's Avatar
 
First Name: Eric
My RZR: 2009 Camo RZR
Member #25854
Join Date: May 2011
Location: Flat Rock IL
Posts: 93
Feedback Score: 0 reviews
View insaneclowns04's Photo Gallery(0)
Re: Low idle when it got hot???

my 09 rzr does this to. i but im pretty sure my fuel pump is geting weak. bec when i frist start my of the day it will idle where suppost to. but when i put t into gear and start to give it gas it will sputter and die sometime. but i dont thing it anything to do with the air filter i think it just the fact it get hot. i been riding on a hot day with two other rzr and theres was doing the same thing as mine and urs. the lowest my got was 698 rpm.
insaneclowns04 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
low idle, not wanting to idle RacerSam Engine and Drivetrain 11 August 7th, 2012 08:05 PM
Does any one know if my pcv adjust idle ? Rzr s idle is low keeps dieing jbadon RZR-S Specific Discussion 8 March 19th, 2012 07:49 AM
Low Idle ??? spovelko Engine and Drivetrain 6 February 15th, 2011 12:37 AM
No Idle CT Willy Engine and Drivetrain 6 May 10th, 2009 04:40 AM
Won't Idle RGERBER General RZR Discussion 8 January 7th, 2008 01:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome