Need some help and ideas guys..... - Polaris RZR Forum - RZR Forums.net
General RZR Discussion For General Polaris RZR discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old May 19th, 2012, 08:35 AM Thread Starter
 
dt3257's Avatar
 
Member #21918
Join Date: Jan 2011
Posts: 54
Feedback Score: 0 reviews
View dt3257's Photo Gallery(0)
Need some help and ideas guys.....

I took my 2011 RZR 50" in for it's first 25 hr service. I got them to change all the fluids and filters etc etc. put on 26" Zillas and got them to check the clutches and belt as it just recently started to be real sluggish down low...acceleration just seems real poor.

Well I get it back and engine light is on, no speedo or odometer and I still have my sluggish problem that they said they fixed.

Of course I am taking it back to them but do you guys have any ideas what could be causing these issues? In case I have to lead the dealer in the right direction as they seem clueless.

2011 RZR800 LE Screamin' Yellow

Pro Armor Doors, "S" flares, Polaris front/rear bumper, roof, rear panel & polaris flip windshield

Now added, 26" Zillas and 1-1/2" spacers :camorzr:
dt3257 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old May 19th, 2012, 09:18 AM
Banned
 
desertvet1990's Avatar
 
First Name: Rick
My RZR: 2015 900S with add ons
Member #15483
Join Date: May 2010
Location: Westminster ,Co
Posts: 8,865
Feedback Score: 11 reviews
View desertvet1990's Photo Gallery(4)
Re: Need some help and ideas guys.....

Are you at altitude? Personally I would put in a clutch spring and weight set for 27" tires and high altitude. Also, get an "S" belt and replace yours and keep the old one with you as a spare. I have an EPI clutchset in mine for just that and run 26.5" tires and do just fine running up to 12,000 feet in Colorado. BTW mine's an '08 standard.

Also sounds like a wire connection or sensor is loose/bad for the speedo stuff
desertvet1990 is offline  
post #3 of 3 Old May 19th, 2012, 10:09 AM
King of crash!
 
johnnycat8's Avatar
 
First Name: john
My RZR: 2nd gen...red
Member #787
Join Date: Dec 2007
Location: roseville calif.
Posts: 31,883
Garage
Feedback Score: 9 reviews
View johnnycat8's Photo Gallery(0) Send a message via Yahoo to johnnycat8
Re: Need some help and ideas guys.....

No speedo = ck eng light. ... They must of left something off. I'd return it for not repairing it but be nice!

link for crow dog's site!!! www.utvguide.net


running makin trax afco shocks and springs
johnnycat8 is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Heard u guys guys were at dirty trutle Catmostfeared Super ATV 0 October 30th, 2010 08:48 PM
IDEAS! Matt20o6 RZR 4 Specific Discussion 4 June 9th, 2010 07:58 AM
Ideas, Ideas, Ideas porkins1180 General RZR Discussion 11 January 22nd, 2010 05:38 PM
Any Ideas? RZR Therapy Lighting, Stereo and Electrical 16 June 14th, 2009 07:54 PM
Need Ideas Joe9216 Projects and How-To 0 April 17th, 2009 10:27 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome