Coolant won't circulate, please help - Polaris RZR Forum - RZR Forums.net
General RZR Discussion For General Polaris RZR discussion. Sponsored by: UTV Gear HQ

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old September 29th, 2018, 07:11 PM Thread Starter
 
blazinrzr's Avatar
 
First Name: Ben
My RZR: '11 XP
Member #16793
Join Date: Jul 2010
Location: California
Posts: 159
Feedback Score: 0 reviews
View blazinrzr's Photo Gallery(0)
Coolant won't circulate, please help

Was driving my 2011 xp 900 in Pismo and was on the gas hard when the coolant hose below the header on the front side of the engine blew. I immediately stopped and shut it down (I thought I was on fire). I replaced the hose filled the system with coolant, then removed the upper hose the radiator topped it off, then pulled the small vent hose at the top of the radiator off and topped it off again. When I fire it up the engine gets to 200 degrees and the radiator fan kicks on but the radiator and hoses that go to the radiator are cold. The engine temp keeps climbing and I have to shut it down. I've tried 3 times and it's the same. What am I doing wrong? Thanks.
blazinrzr is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old September 29th, 2018, 07:41 PM
 
Clothier's Avatar
 
First Name: Brian
My RZR: 2012 800S Black/White/Red LE
Member #65577
Join Date: Feb 2014
Location: Somerset, Ky
Posts: 3,283
Garage
Feedback Score: 0 reviews
View Clothier's Photo Gallery(0)
Re: Coolant won't circulate, please help

Try this.

,

Shock Therapy, Super Atv, RT Pro(Racertech), Utv Inc, Factory Utv, Thunderhawk, Super Dave's Bushings, Garage Products Inc., Team FAS Motorsports, OTRATTW, Hunterworks, JJ and A Racing, Gilbert's Custom Utv's, Twisted Werkz Offroad, 606 Offroad, Harts Motorsports Somerset, Ky
Clothier is offline  
post #3 of 5 Old September 29th, 2018, 07:43 PM Thread Starter
 
blazinrzr's Avatar
 
First Name: Ben
My RZR: '11 XP
Member #16793
Join Date: Jul 2010
Location: California
Posts: 159
Feedback Score: 0 reviews
View blazinrzr's Photo Gallery(0)
Re: Coolant won't circulate, please help

Thanks, I'll try it tomorrow.
blazinrzr is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old October 1st, 2018, 09:29 PM
 
claas's Avatar
 
Member #85471
Join Date: Oct 2015
Posts: 151
Feedback Score: 0 reviews
View claas's Photo Gallery(0)
Re: Coolant won't circulate, please help

To make the bleeding process faster, jack the front end up and then crack that bleeder screw and it should do the trick done this multiple times on a 900


Sent from my iPhone using Tapatalk
claas is online now  
post #5 of 5 Old October 1st, 2018, 10:03 PM Thread Starter
 
blazinrzr's Avatar
 
First Name: Ben
My RZR: '11 XP
Member #16793
Join Date: Jul 2010
Location: California
Posts: 159
Feedback Score: 0 reviews
View blazinrzr's Photo Gallery(0)
Re: Coolant won't circulate, please help

Thanks for the replys. I was able to bleed most of the system, but I've got bigger problems now. Its got at least a blown head gasket. Combustion gases are coming out of the coolant filler neck and the oil tank.
blazinrzr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Losing Coolant??? sceblack RZR XP 4 900 Specific Discussion 6 June 13th, 2018 08:57 AM
Coolant gauge jack.andy.568 General RZR Discussion 0 December 17th, 2017 07:50 AM
Reservoir coolant machinist1 RZR 900 Engine 0 November 28th, 2017 05:48 PM
coolant loss Rode Warrior RZR 800 Specific Discussion 4 August 30th, 2016 04:45 AM
207 miles and found coolant under oil filter Dunegoon16 RZR XP Turbo 5 July 17th, 2016 09:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome