Cleaning battery and winch solenoid of mud and silt - Polaris RZR Forum - RZR Forums.net
General RZR Discussion For General Polaris RZR discussion. Sponsored by: UTV Gear HQ

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old May 30th, 2017, 04:57 PM Thread Starter
 
Woodys2718's Avatar
 
My RZR: 2017 RZR S 1000 EPS
Member #186777
Join Date: Mar 2017
Location: Janesville, WI
Posts: 100
Garage
Feedback Score: 0 reviews
View Woodys2718's Photo Gallery(0)
Cleaning battery and winch solenoid of mud and silt

I just got back from a 370 mile Memorial Day weekend ride. I went through some pretty deep mud holes which filled the cab with some mud and silt.

What's the best way to clean off the battery and winch solenoid? Disconnect and remove to clean or leave in machine disconnect and lightly hose off?

Woodys2718 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old May 31st, 2017, 04:38 AM
 
chak's Avatar
 
Member #84673
Join Date: Sep 2015
Posts: 28
Feedback Score: 0 reviews
View chak's Photo Gallery(0)
Re: Cleaning battery and winch solenoid of mud and silt

I just cleaned mine with a electric 2030psi pressure washer. Just used a 45deg tip and kept my distance. Works fine just watch you angles on the fuse box seal .

Sent from my SM-G955U using Tapatalk
chak is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome