Ran out of gas and now sputtering and back firing - Polaris RZR Forum - RZR Forums.net
General RZR Discussion For General Polaris RZR discussion. Sponsored by: UTV Gear HQ

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old May 15th, 2017, 07:40 PM Thread Starter
 
tystang2001's Avatar
 
My RZR: 2011 rzr 900xp, 2017 rzr 4xp1000
Member #173625
Join Date: Dec 2016
Location: Southern Ohio
Posts: 97
Feedback Score: 0 reviews
View tystang2001's Photo Gallery(0)
Ran out of gas and now sputtering and back firing

Went riding all weekend at ride royal blue. At the very end of the ride started running out of gas up a hill. It sputtered to the top. Friends ran down to the bottom and got some fuel and we put some in.

Now the rzr is backfiring especially and deceleration and sputtering. If I hammer into it seems to run fine with good power. It was dying if I let it idle but about about another gallon or so of more gas in it today and it now stays running when idle.

Any ideas? The rzr is a 2011 900xp with a brand new motor.
tystang2001 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome