Rugged Radio 60w - Polaris RZR Forum - RZR Forums.net
General RZR Discussion For General Polaris RZR discussion. Sponsored by: UTV Gear HQ

 
LinkBack Thread Tools Display Modes
post #1 of 11 Old March 26th, 2017, 11:43 AM Thread Starter
 
Jeepalive's Avatar
 
Member #73647
Join Date: Oct 2014
Posts: 91
Feedback Score: 0 reviews
View Jeepalive's Photo Gallery(0)
Rugged Radio 60w

I have the 60watt with 660 intercom and I can hear people clear as day but they can't hear me, with PTT or the mic, does anyone know something to look for? It worked great for a few months but now doesn't, I have the antenna mounted on Polaris aluminum roof ran along the cage to the dash where it's plugged into the 60w, not coiled up anywhere ... any help is very appreciated! Thank you
Jeepalive is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old March 26th, 2017, 01:22 PM
 
oprlrt's Avatar
 
First Name: Lee
My RZR: 2015 xp 1000
Member #98681
Join Date: Jan 2016
Location: Rocklin, Ca.
Posts: 19
Feedback Score: 0 reviews
View oprlrt's Photo Gallery(0)
Re: Rugged Radio 60w

After working on computers for a long time you look for the simple stuff first. Make sure mike is plugged in and when you key it you see light on front of radio light up. Call Rugged those guys are good and will tell you all the short cuts to get back up and running quick. You can also ask a ham person if you know one they are usually very help full.
Lee
oprlrt is offline  
post #3 of 11 Old March 26th, 2017, 01:27 PM Thread Starter
 
Jeepalive's Avatar
 
Member #73647
Join Date: Oct 2014
Posts: 91
Feedback Score: 0 reviews
View Jeepalive's Photo Gallery(0)
Re: Rugged Radio 60w

Quote:
Originally Posted by oprlrt View Post
After working on computers for a long time you look for the simple stuff first. Make sure mike is plugged in and when you key it you see light on front of radio light up. Call Rugged those guys are good and will tell you all the short cuts to get back up and running quick. You can also ask a ham person if you know one they are usually very help full.

Lee


Mic and PTT both light up when I key them, and other radios can see something key on there end but can't hear.
I'll be giving rugged a call Monday, I called them last week and they told me to look at the way the antenna is run make sure it's not coiled which it was at first but I changed that just now trying to see if that works. My brother and father both have this setup in their RZR's that I put in and don't have any issues with them..
Thank you for the help
Jeepalive is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old March 26th, 2017, 02:03 PM
 
oprlrt's Avatar
 
First Name: Lee
My RZR: 2015 xp 1000
Member #98681
Join Date: Jan 2016
Location: Rocklin, Ca.
Posts: 19
Feedback Score: 0 reviews
View oprlrt's Photo Gallery(0)
Re: Rugged Radio 60w

You could try your brother or fathers mike if they screw in or have an rj45 type end to see if it is the mike. Of course you will need some one to talk to, you can also look at where cable is sodered on antenna to make sure one of the two wires are not broke or partially broke. Over my head but some power sources like an amp might also be a problem as to where antenna runs.
Lee
oprlrt is offline  
post #5 of 11 Old March 26th, 2017, 02:18 PM
Premium Member
 
pkrider's Avatar
 
First Name: Philip
My RZR: 2015 xp4 1000 white lightning monochorme
Member #76863
Join Date: Jan 2015
Location: So. Cal
Posts: 1,601
Garage
Feedback Score: 1 reviews
View pkrider's Photo Gallery(0)
Re: Rugged Radio 60w

Quote:
Originally Posted by Jeepalive View Post
I have the 60watt with 660 intercom and I can hear people clear as day but they can't hear me, with PTT or the mic, does anyone know something to look for? It worked great for a few months but now doesn't, I have the antenna mounted on Polaris aluminum roof ran along the cage to the dash where it's plugged into the 60w, not coiled up anywhere ... any help is very appreciated! Thank you

Are you using the hand held mic or helmet kit?? If it was working before fine then I doubt its the antenna. I had the same issue and mine was the helmet kit mic. Changed it out and it was fine. If not, check your mic pin connection.

When you stop holding people accountable, you lose the right to lead!
pkrider is offline  
post #6 of 11 Old March 26th, 2017, 02:29 PM Thread Starter
 
Jeepalive's Avatar
 
Member #73647
Join Date: Oct 2014
Posts: 91
Feedback Score: 0 reviews
View Jeepalive's Photo Gallery(0)
Re: Rugged Radio 60w

Quote:
Originally Posted by pkrider View Post
Quote:
Originally Posted by Jeepalive View Post
I have the 60watt with 660 intercom and I can hear people clear as day but they can't hear me, with PTT or the mic, does anyone know something to look for? It worked great for a few months but now doesn't, I have the antenna mounted on Polaris aluminum roof ran along the cage to the dash where it's plugged into the 60w, not coiled up anywhere ... any help is very appreciated! Thank you

Are you using the hand held mic or helmet kit?? If it was working before fine then I doubt its the antenna. I had the same issue and mine was the helmet kit mic. Changed it out and it was fine. If not, check your mic pin connection.


It's the same with all, mic, helmet kit and headsets I've tried all 4 I have.
Yeah I wasn't thinking it was the antenna, before it worked great up until about 2 months ago but haven't had time to mess with it until now
Jeepalive is offline  
post #7 of 11 Old March 26th, 2017, 02:32 PM Thread Starter
 
Jeepalive's Avatar
 
Member #73647
Join Date: Oct 2014
Posts: 91
Feedback Score: 0 reviews
View Jeepalive's Photo Gallery(0)
Re: Rugged Radio 60w

Quote:
Originally Posted by oprlrt View Post
You could try your brother or fathers mike if they screw in or have an rj45 type end to see if it is the mike. Of course you will need some one to talk to, you can also look at where cable is sodered on antenna to make sure one of the two wires are not broke or partially broke. Over my head but some power sources like an amp might also be a problem as to where antenna runs.

Lee


Just tested my mic from my dads radio and I could hear the receiving from my radio but can't hear when I try to transmit from my radio to his
Jeepalive is offline  
post #8 of 11 Old March 26th, 2017, 03:52 PM
 
oprlrt's Avatar
 
First Name: Lee
My RZR: 2015 xp 1000
Member #98681
Join Date: Jan 2016
Location: Rocklin, Ca.
Posts: 19
Feedback Score: 0 reviews
View oprlrt's Photo Gallery(0)
Re: Rugged Radio 60w

Then it is not mic, if you have an extra antenna you could plug that in you will have to ground it but if that works you will have narrowed it down to that. Rugged will be able to tell you about what can go wrong in the radio itself. Good luck.
Lee
oprlrt is offline  
post #9 of 11 Old March 26th, 2017, 04:02 PM Thread Starter
 
Jeepalive's Avatar
 
Member #73647
Join Date: Oct 2014
Posts: 91
Feedback Score: 0 reviews
View Jeepalive's Photo Gallery(0)
Re: Rugged Radio 60w

Quote:
Originally Posted by oprlrt View Post
Then it is not mic, if you have an extra antenna you could plug that in you will have to ground it but if that works you will have narrowed it down to that. Rugged will be able to tell you about what can go wrong in the radio itself. Good luck.

Lee


Didn't even think about that! I'll have to try that I can just take my radio and put it in my dads rzr to check.
Thank you!
Jeepalive is offline  
post #10 of 11 Old March 27th, 2017, 05:03 AM
jvt
Enumclaw,wa
 
jvt's Avatar
 
Member #143993
Join Date: Jul 2016
Posts: 27
Feedback Score: 0 reviews
View jvt's Photo Gallery(0)
Re: Rugged Radio 60w

the radiation is strong at 60w so when you get it working a lower setting is better when distance or terrain is good. don't let any metal touch the metal on the antenna when transmitting on high.
jim
jvt is offline  
post #11 of 11 Old March 27th, 2017, 11:42 AM
 
Mschriever's Avatar
 
First Name: Mike
My RZR: 2016 Xpt4
Member #128329
Join Date: May 2016
Location: Slc utah
Posts: 8
Feedback Score: 0 reviews
View Mschriever's Photo Gallery(0)
Re: Rugged Radio 60w

I've had this problem twice. First time was the jumper between the radio and intercom was not quite plugged in all the way. Second time was after some work i had put the wrong ptt to the wrong headset.

Sent from my SM-G925V using Tapatalk
Mschriever is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rugged Radios AlphaBass Headset ruggbutt General RZR Discussion 25 June 5th, 2018 05:28 AM
Rugged Radio issue bigb10b General RZR Discussion 8 November 5th, 2016 10:09 AM
Rugged Radio VX2200 install protector RZR S 900 26 June 29th, 2016 08:52 AM
Where did you mount your Rugged Radio antenna? obrien_rzr RZR S 900 2 May 6th, 2016 05:30 PM
Rugged Radio Mount for 800/900 bennydog Polaris RZR Parts For Sale 1 February 18th, 2016 08:26 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome