Lean/rough idle/slow - Polaris RZR Forum - RZR Forums.net
Engine and Drivetrain For discussion of drivetrain and engine performance and maintenance

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old June 5th, 2017, 01:03 PM Thread Starter
 
boosted2g's Avatar
 
Member #197033
Join Date: May 2017
Posts: 31
Feedback Score: 0 reviews
View boosted2g's Photo Gallery(0)
Lean/rough idle/slow

Guys, I really need some help. I have a 2010 800s . I have been fighting the idle for some time. So last night I was adjusting the tps and the afr jumped from 12-13 idle all the way to 17+. So today I pull everything apart. I just replaced the throttle cable also. So I pull the throttle body off and remove the cable. Back the idle base voltage screw to where it wasn't touching the cam. I set the tps to .528 and verified the butterfly was closed. I turned the idle screw back in till I reached .735. Reinstalled the throttle cable and set it so that when I barely touch the gas the throttle cam will move. Fire it up and the idle is now around 1100 and the tps is reading .75. So I backed the idle screw down to be back at .735 while idling. The problem is that my afr is still reading 16+ at idle. When I give it gas it shoots down to the 11's and 12's but when I let off it goes right back up. When I took it for a test drive it was so slow at accelerating I could have probably out ran it. Couldn't really get the rpms past 3600. What am I missing here???

Sent from my SM-G935T using Tapatalk
boosted2g is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome