my 4x4 problem...found - Page 3 - Polaris RZR Forum - RZR Forums.net
Engine and Drivetrain For discussion of drivetrain and engine performance and maintenance

Reply
 
LinkBack Thread Tools Display Modes
post #31 of 32 Old June 24th, 2015, 02:55 PM
 
8thNotch's Avatar
 
Member #82368
Join Date: Jun 2015
Posts: 14
Feedback Score: 0 reviews
View 8thNotch's Photo Gallery(0)
Re: my 4x4 problem...found

Subscribe


Let it rip!
8thNotch is offline  
Sponsored Links
Advertisement
 
post #32 of 32 Old April 16th, 2019, 08:13 AM
 
Jmcyps's Avatar
 
Member #268596
Join Date: Apr 2019
Posts: 1
Feedback Score: 0 reviews
View Jmcyps's Photo Gallery(0)
Johnnycat8 I know it’s been a long time but could you get pictures of everything by chance? My rzr is having this problem with the high gear not showing and I’d like to fix it myself but am not nearly as good at this as you. I can’t find any diagrams showing where these switches and sensors are. Thanks
Jmcyps is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Found my way over quadnkev Member Introductions 23 November 23rd, 2010 01:50 AM
found this Aharzr Forced Induction 1 September 24th, 2009 01:46 PM
Finally Found You! LadyRed Member Introductions 9 June 16th, 2009 08:02 AM
Look what I found in the Manual... Kid Dynomite General RZR Discussion 6 May 16th, 2009 11:12 PM
Replacing Stock Air Box and found problem... stprzr Engine and Drivetrain 3 November 24th, 2008 10:04 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome