09 800 Slow out of the hole. HELP!!! - Polaris RZR Forum - RZR Forums.net
Engine and Drivetrain For discussion of drivetrain and engine performance and maintenance

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old April 23rd, 2013, 09:56 PM Thread Starter
 
fatboyracing's Avatar
 
Member #54746
Join Date: Apr 2013
Posts: 2
Feedback Score: 0 reviews
View fatboyracing's Photo Gallery(0)
09 800 Slow out of the hole. HELP!!!

I've got a 2009 RZR, I have recently tubed it out and built RZR-S A arms and decided it needed more OOMPH, so I ordered a Trinity Racing 820 big bore kit and a 981 grind Webcam. I have a dynatek programmable ECU that I have been tinkering with, but nothing seems to change the bogg out of the hole. I put in a red EPI primary spring and a green EPI secondary spring with 21-74 weights in the clutch and my rev limit is set at 7000, when it finally turns on it grabs and holds at about 6600 RPMs, so it seems as if the clutch is tuned pretty well. At an off idle punch, it just seems to be sick, I know my cam makes mid-hi RPM power, but I feel like it is weaker than it should be out of the hole. Does anyone out there have a similar set up? Or do maybe some of you Polaris gurus think it sounds like a clutching problem or more of an engine problem? Please help me out guys, I am at my wits end with this rig!
fatboyracing is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old April 24th, 2013, 03:19 AM
 
PhiberOptik's Avatar
 
Member #36019
Join Date: Feb 2012
Location: Victoria BC
Posts: 475
Feedback Score: 3 reviews
View PhiberOptik's Photo Gallery(0)
Re: 09 800 Slow out of the hole. HELP!!!

Maybe you need adjustable weights in the primary to really dial the clutches in, sounds like too much heel weight is preventing the rpm from climbing as quickly down low, but this also could be a function of the cams operating range

RZR Z1 Turbo + Everything
PhiberOptik is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
slow to go amunro RZR 170 Specific Disccusion 7 April 3rd, 2013 09:17 PM
Slow rzr? SLDHVN RZR-S Specific Discussion 22 March 5th, 2013 11:11 AM
old and slow redbull Member Introductions 28 December 8th, 2011 06:58 PM
Wow, my RZR is slow now! WOLF1 General RZR Discussion 5 April 27th, 2011 11:42 AM
FST intake = slow, hella slow. HWY64T&A Engine and Drivetrain 3 October 5th, 2009 07:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome