Rzr 900 coolant issue - Polaris RZR Forum - RZR Forums.net

RZR XP 900 2011 to 2014 Polaris RZR XP 900 Forum on RZRForums.net

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old December 27th, 2012, 07:09 PM Thread Starter
Feedback Score: 0 reviews
 
Jmccart's Avatar
 
Join Date: Nov 2011
Posts: 81
Rzr 900 coolant issue

Hey I've got a 2011 900 xp with 1000 miles, recently I've been smelling coolant and loosing it, I've pulled the skid plate, the rear cover for all the bad spots, checked wp, no visible sign of coolant leaks, oil is clean, but I can smell it, anyone ever had internal leak issues??
Jmccart is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old December 27th, 2012, 08:44 PM
Feedback Score: 0 reviews
 
ohana1's Avatar
 
Join Date: Nov 2010
Location: Henderson,NV
Posts: 79
Re: Rzr 900 coolant issue

look near the hose that goes into the motor had the same issue. The bolts on the houseing came loose and was dripping. Hope this will help.
ohana1 is offline  
post #3 of 3 Old December 27th, 2012, 09:15 PM Thread Starter
Feedback Score: 0 reviews
 
Jmccart's Avatar
 
Join Date: Nov 2011
Posts: 81
Re: Rzr 900 coolant issue

Thanks ill check it out tomorrow I can't find any wet spots
Jmccart is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
rzrs fan and coolant issue kijijikid RZR-S Specific Discussion 8 January 18th, 2017 05:24 AM
2011 rzr xp coolant issue rzrxp7 RZR 900 Engine 3 September 19th, 2012 06:08 PM
fuel pump issue or ECM issue? chunks7mm General RZR Discussion 3 September 17th, 2011 12:46 PM
Coolant issue MikeyM Engine and Drivetrain 2 March 25th, 2011 09:15 PM
Coolant baldeagle7 General RZR Discussion 7 July 6th, 2010 05:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome