check engine error code 65590 - Polaris RZR Forum - RZR Forums.net

RZR XP 1000 Discussions for the all new Polaris RZR XP 1000

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 34 Old April 9th, 2016, 02:05 PM Thread Starter
 
Taj2010's Avatar
 
Member #46039
Join Date: Oct 2012
Posts: 8
Feedback Score: 0 reviews
View Taj2010's Photo Gallery(0)
check engine error code 65590

2016 xp 1000 unloaded from trailer less than 1 mile on new machine just picked today and check engine light on error code 65590. Any one know what this code means.?
Taj2010 is offline  
Sponsored Links
Advertisement
 
post #2 of 34 Old April 10th, 2016, 02:13 PM Thread Starter
 
Taj2010's Avatar
 
Member #46039
Join Date: Oct 2012
Posts: 8
Feedback Score: 0 reviews
View Taj2010's Photo Gallery(0)
Angry Re: check engine error code 65590

Anybody ever have these codes 0 65590 and another code today 1 65591 and both code have 7 at the bottom of the display .
Taj2010 is offline  
post #3 of 34 Old April 10th, 2016, 02:16 PM
 
Zebrock's Avatar
 
My RZR: 2016 RZR 1000 XP4
Member #49982
Join Date: Jan 2013
Location: Orange County, CA
Posts: 61
Feedback Score: 0 reviews
View Zebrock's Photo Gallery(0)
Re: check engine error code 65590

Time to pack that thing back up onto the trailer and back to the dealer.
Zebrock is offline  
Sponsored Links
Advertisement
 
post #4 of 34 Old May 6th, 2016, 09:08 PM
 
Gonzo009's Avatar
 
Member #128569
Join Date: May 2016
Posts: 1
Feedback Score: 0 reviews
View Gonzo009's Photo Gallery(0)
Quote:
Originally Posted by Taj2010 View Post
Anybody ever have these codes 0 65590 and another code today 1 65591 and both code have 7 at the bottom of the display .
Did you find what these codes are? I just got the same ones on my rzr.
Gonzo009 is offline  
post #5 of 34 Old May 30th, 2016, 07:09 PM
 
keith stone's Avatar
 
My RZR: Xp 1000 4
Member #24580
Join Date: Apr 2011
Location: New Mexico
Posts: 65
Feedback Score: 0 reviews
View keith stone's Photo Gallery(0)
Re: check engine error code 65590

I got the same error code this weekend and don't see it in any of the charts.65590 and 65592.
keith stone is offline  
post #6 of 34 Old May 31st, 2016, 09:46 AM
 
volute's Avatar
 
My RZR: RZR 1000 / XPT
Member #133281
Join Date: May 2016
Location: Wyoming
Posts: 5
Garage
Feedback Score: 0 reviews
View volute's Photo Gallery(0)
Re: check engine error code 65590

Quote:
Originally Posted by keith stone View Post
I got the same error code this weekend and don't see it in any of the charts.65590 and 65592.
I have heard these codes are from the polaris recall update. Misfire codes or something. Maybe there is a recall for the recall.
volute is offline  
post #7 of 34 Old May 31st, 2016, 01:23 PM
 
keith stone's Avatar
 
My RZR: Xp 1000 4
Member #24580
Join Date: Apr 2011
Location: New Mexico
Posts: 65
Feedback Score: 0 reviews
View keith stone's Photo Gallery(0)
Re: check engine error code 65590

Talked to the dealer today and he said 65590 is a misfire code 65591 is misfire cylinder 1 and 65592 is cylinder 2.
keith stone is offline  
post #8 of 34 Old June 11th, 2016, 09:45 PM
 
clsr79's Avatar
 
First Name: Big G
My RZR: Rzr 4 1000
Member #84735
Join Date: Sep 2015
Location: Riverside, CA
Posts: 48
Feedback Score: 1 reviews
View clsr79's Photo Gallery(0)
Re: check engine error code 65590

Quote:
Originally Posted by keith stone View Post
Talked to the dealer today and he said 65590 is a misfire code 65591 is misfire cylinder 1 and 65592 is cylinder 2.

Did they say why they came on or how to clear them? I just had my recalls done and drove it around the block and got both codes, I will be calling the dealer on Monday. There was nothing wrong with my rzr and now I have this done and I have 2 codes
clsr79 is offline  
post #9 of 34 Old June 12th, 2016, 10:22 AM
 
keith stone's Avatar
 
My RZR: Xp 1000 4
Member #24580
Join Date: Apr 2011
Location: New Mexico
Posts: 65
Feedback Score: 0 reviews
View keith stone's Photo Gallery(0)
Re: check engine error code 65590

I was told to check my belt and change my spark plugs. The alarm will clear once the motor runs an certain amount of revolution without detecting a misfire.
keith stone is offline  
post #10 of 34 Old July 23rd, 2016, 01:14 PM
 
cp434's Avatar
 
First Name: Chris
My RZR: 2015 1000 XP4
Member #140705
Join Date: Jun 2016
Location: Pierce County, Washington
Posts: 101
Feedback Score: 0 reviews
View cp434's Photo Gallery(0)
Re: check engine error code 65590

Same codes. Did the spark plugs and belt fix the issue? (I am really struggling to buy into this as I have a new belt and cannot imagine the plugs are bad already.)
cp434 is offline  
post #11 of 34 Old July 24th, 2016, 01:16 PM
 
keith stone's Avatar
 
My RZR: Xp 1000 4
Member #24580
Join Date: Apr 2011
Location: New Mexico
Posts: 65
Feedback Score: 0 reviews
View keith stone's Photo Gallery(0)
Re: check engine error code 65590

It corrected my problem. I did notice a flat spot on my belt.
keith stone is offline  
post #12 of 34 Old July 24th, 2016, 03:49 PM
 
cp434's Avatar
 
First Name: Chris
My RZR: 2015 1000 XP4
Member #140705
Join Date: Jun 2016
Location: Pierce County, Washington
Posts: 101
Feedback Score: 0 reviews
View cp434's Photo Gallery(0)
Re: check engine error code 65590

Quote:
Originally Posted by keith stone View Post
It corrected my problem. I did notice a flat spot on my belt.
Wow! So anytime a belt slips we are to expect the machine to nearly shut down and pop an error code? This could be dangerous given the right situation.
Dang, there must be a way to stop a slipping belt from doimg this...
cp434 is offline  
post #13 of 34 Old July 24th, 2016, 03:51 PM
 
joekamkod's Avatar
 
First Name: Joe
My RZR: 2016 turbo 2016 xp1000 2017 general 4
Member #27276
Join Date: Jun 2011
Location: Ofallon Missouri
Posts: 1,067
Garage
Feedback Score: 1 reviews
View joekamkod's Photo Gallery(0)
Re: check engine error code 65590

I got the codes and changed the spark plugs and no more codes so far .
joekamkod is online now  
post #14 of 34 Old November 12th, 2016, 07:12 AM
 
Banshee Matt's Avatar
 
Member #9322
Join Date: Aug 2009
Posts: 21
Feedback Score: 0 reviews
View Banshee Matt's Photo Gallery(0)
Anymore info on these codes. My buddy is in Glamis on his first trip out on his new 1000 turbo. He said plugs are brand new and. Belt. Like 2 miles on it
Banshee Matt is offline  
post #15 of 34 Old November 26th, 2016, 08:16 AM
 
CaptainYARRR's Avatar
 
Member #88097
Join Date: Nov 2015
Posts: 281
Feedback Score: 0 reviews
View CaptainYARRR's Photo Gallery(0)
Anyone figure this out? Getting these codes. Checked my belt and it looks great. I also struggle to think the plugs can go bad so fast.
CaptainYARRR is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Check emgine light comes on and engine shuts down and the codes refer to tps 1 and 2 Boucher RZR XP 1000 3 April 14th, 2016 09:41 PM
Check engine light HELP Langhammx RZR XP Turbo 6 March 28th, 2016 02:05 AM
Need Help Diagnosing Check Engine Light Powdered Toastman Forum Help, Questions and Info 3 March 9th, 2016 11:02 AM
'12 RZR 900 Check engine 51 with stuttering? JumpMaster82d Engine and Drivetrain 1 March 5th, 2016 03:48 AM
check engine light won't go out gooberff RZR XP 1000 1 November 19th, 2015 12:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome