2010 rzr s stalls on hills only - Polaris RZR Forum - RZR Forums.net

RZR-S Specific Discussion Please limit this to RZR-S 800 discussions only.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old October 21st, 2012, 03:07 PM Thread Starter
Feedback Score: 0 reviews
 
dunavantsbodyshop's Avatar
 
Join Date: Oct 2012
Posts: 2
Garage
2010 rzr s stalls on hills only

My rzr stalls on steep bumpy hills only time it ever happens..dealer said change plugs and add seafoam to gas so i did all that even drained the gas rode it at a ride after it was fine..today i go on another ride and it does the same thing it sputters dies and most of the time loses all power as far as electrical and wont start back until cutting the key on and off a few times or waiting 30 seconds or so... afterwards if you try to throttle it it will usually dies again unless you barely touch the throttle its pretty irritating also has brand new battery dunno what else to do check engine light flashed a few times after it died today but then just stopped and went off..dealer says cant check unless it's on so im at a loss any help would be great thanks
dunavantsbodyshop is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old October 22nd, 2012, 04:36 PM
Feedback Score: 1 reviews
 
JiAnthony315's Avatar
 
Join Date: Mar 2012
Location: Eastern, NC
Posts: 1,441
Re: 2010 rzr s stalls on hills only

If your engine light comes on you should be able to check the code it is throwing...Also i may be wrong but I think if the engine light comes on it stores it in the computer whether it stays on or not...

Also have you checked you fuel pressure when it is messing up? If not do that because my fuel pump went out...As far as doing it just on hills, I have no idea about that..
JiAnthony315 is offline  
post #3 of 3 Old October 22nd, 2012, 06:03 PM Thread Starter
Feedback Score: 0 reviews
 
dunavantsbodyshop's Avatar
 
Join Date: Oct 2012
Posts: 2
Garage
Re: 2010 rzr s stalls on hills only

Thanks for your help i think i may have found the problem...someone spliced the hot ignition wire at one time and didnt use the right connectors...i messed with it today and figured out it was my electrical problem anyways as they were pretty much just staying together by the other wires pushing against it..as for fuel pressure im gonna check that tomorrow thanks for your help i really appreciate it
dunavantsbodyshop is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
170 stalls when you touch pedal WChighfill RZR 170 Specific Disccusion 15 July 6th, 2012 01:13 PM
170 stalls on whoops WChighfill RZR 170 Specific Disccusion 2 May 23rd, 2012 08:59 AM
RZR 170 stalls in a right turn CoryD RZR 170 Specific Disccusion 3 January 20th, 2011 05:48 PM
rzr 4 sputters,backfires,stalls out riverride Engine and Drivetrain 9 February 9th, 2010 08:35 AM
Low Idle and stalls Kragar General RZR Discussion 1 June 7th, 2009 11:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome