Front cylinder not firing!! - Polaris RZR Forum - RZR Forums.net

RZR-S Specific Discussion Please limit this to RZR-S 800 discussions only.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old August 1st, 2011, 08:17 PM Thread Starter
Feedback Score: 0 reviews
 
spoon6968's Avatar
 
Join Date: Feb 2011
Posts: 1
Front cylinder not firing!!

My RZR recently started idling rough and lost all power. I have narrowed it down to the front cylinder not firing. I have tried changing the plug and wire but still nothing. The coil seems to be working because if you switch the rear cylinder wire, it fires on both sides of coil. Any ideas what I need to check next? Something fuel related? Started happening after running in deep water,
spoon6968 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you know if both cylinders are firing. bruteman750 Engine and Drivetrain 19 September 15th, 2012 03:52 PM
800 firing question. Gundog Engine and Drivetrain 3 March 1st, 2011 10:48 PM
New cylinder $150.00 sharktank Engine and Drivetrain 6 November 13th, 2010 08:44 PM
Engine back-firing TPL33 General RZR Discussion 3 November 17th, 2009 05:44 AM
Cylinder noodles Want to Buy 0 June 17th, 2009 06:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome