Cv joints clicking on hard turns then stops. - Polaris RZR Forum - RZR Forums.net

RZR 800 Specific Discussion Discussions dedicated to the standard RZR 800 50 model

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old January 24th, 2014, 04:40 PM Thread Starter
Feedback Score: 0 reviews
 
dezs1775's Avatar
 
Join Date: Dec 2010
Posts: 196
Garage
Cv joints clicking on hard turns then stops.

2010 rzr le put a R/t lift and heavy duty springs on, also r/t and now the fun part. After a few months the cv joints click on pavement but after about 15 to 20 minutes of ridding they stop and no more clicking. You think there is to much spring and not enough weight on them to compress them to a safe non cv clicking level?
dezs1775 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old January 24th, 2014, 04:45 PM
Feedback Score: 0 reviews
 
darkstar_420's Avatar
 
Join Date: Sep 2011
Location: Canada
Posts: 1,892
Re: Cv joints clicking on hard turns then stops.

I think your too high with both the lift and springs, jack it up and spin the tires when they are hanging, it its clicking I would lose the lift or the springs

2011 Screamin' Yellow RZR S

darkstar_420 is offline  
post #3 of 5 Old January 24th, 2014, 04:50 PM Thread Starter
Feedback Score: 0 reviews
 
dezs1775's Avatar
 
Join Date: Dec 2010
Posts: 196
Garage
Re: Cv joints clicking on hard turns then stops.

No clicking when all jacked up, it only happens when you first start out, then it quits. I think your right. Time to change out the shocks. I like elka shocks any better ones than them?
dezs1775 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old January 24th, 2014, 04:58 PM
Feedback Score: 0 reviews
 
darkstar_420's Avatar
 
Join Date: Sep 2011
Location: Canada
Posts: 1,892
Re: Cv joints clicking on hard turns then stops.

im not sure what the best shocks would be for a 50", I heard carl's fox shox are good

2011 Screamin' Yellow RZR S

darkstar_420 is offline  
post #5 of 5 Old January 27th, 2014, 05:23 PM Thread Starter
Feedback Score: 0 reviews
 
dezs1775's Avatar
 
Join Date: Dec 2010
Posts: 196
Garage
Re: Cv joints clicking on hard turns then stops.

Ok, did some measuring tonight. With the racer tech heavy duty springs and lift it put me at 14" of ground clearance. That is why my rear axles are binding on turns on pavement. So, time to order new shocks and drop it down a few inches.
dezs1775 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turns over but won't start billybob974 RZR 170 Specific Disccusion 6 May 29th, 2014 11:54 AM
No fire but turns over Nickaloden RZR-S Specific Discussion 2 May 23rd, 2013 08:42 AM
RZR 170 turns over but will not start rcoman RZR 170 Specific Disccusion 1 January 3rd, 2012 01:14 PM
4WD turns itself off? Jaybo RZR XP 900 24 August 15th, 2011 01:21 PM
Turns over but no spark shanek62 RZR-S Specific Discussion 4 June 11th, 2011 03:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome