Polaris RZR Forum

170 Engine troubles!!!!!!!!

This is a discussion on 170 Engine troubles!!!!!!!! within the RZR 170 Specific Disccusion forums, part of the General RZR category; Any one elese out here have problems with thier 170's lossing compression and starting to smoke. Also what kind of riding conditions do you ride ...


Go Back   Polaris RZR Forum - RZR Forums.net > General RZR > RZR 170 Specific Disccusion

RZR 170 Specific Disccusion For all discussions about our little buddy - the Polaris RZR 170 and the RZR 170 EFI!

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old February 14th, 2010, 05:42 PM
linrobelf's Avatar
Team Orange Crush
Feedback Score: 0 reviews
 
First Name: Linda, Robert or Kids
My RZR: Rzr 800 LE, Rzr 170 Dirty
Member #13176
Join Date: Feb 2010
Location: Kent, Washington
Posts: 17
View linrobelf's Photo Gallery(0)
Dollarsign 170 Engine troubles!!!!!!!!

Any one elese out here have problems with thier 170's lossing compression and starting to smoke. Also what kind of riding conditions do you ride with your 170?
Reply With Quote
Sponsored Links
RZRForums.net is the premier Polaris RZR Forum on the internet. Registered Users do not see these ads. Please Register - It's Free!
  #2  
Old February 14th, 2010, 06:05 PM
TahoeTracker's Avatar
Feedback Score: 0 reviews
 
Member #7644
Join Date: May 2009
Posts: 129
View TahoeTracker's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

I'm sure you changed the intake before you let the kids ride it....right??? If not, there is your answer. If you have changed it, well I don't know for sure. My kids 170 is ridden in Nevada...VERY DUSTY! and no problems with the new intake system by Factory UTV IF still under warranty, take it back to your dealer and let them fix it. Hope you get to the bottom of it.
Reply With Quote
  #3  
Old February 14th, 2010, 06:56 PM
linrobelf's Avatar
Team Orange Crush
Feedback Score: 0 reviews
 
First Name: Linda, Robert or Kids
My RZR: Rzr 800 LE, Rzr 170 Dirty
Member #13176
Join Date: Feb 2010
Location: Kent, Washington
Posts: 17
View linrobelf's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

No we didnt put on the intake before going to the dunes, BIG mistake. After only 10 hours in the dunes the bore is ruined and there is no compression and it burnes oil. regretting not puting on the vent racing intake before going thanx for your concern and input.
Reply With Quote
  #4  
Old February 14th, 2010, 07:53 PM
TahoeTracker's Avatar
Feedback Score: 0 reviews
 
Member #7644
Join Date: May 2009
Posts: 129
View TahoeTracker's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

Pretty sad that all the rzr's have such junk for an intake. You would think that they would be able to fix the issue after so many complaints and issues with it. Hard to believe after spending thousands of dollars on a UTV you have to go buy an aftermarket product to make the thing run correctly. I will say that I love my "S" and the kids love their 170
Reply With Quote
  #5  
Old February 14th, 2010, 08:01 PM
SPCAS40's Avatar
Feedback Score: 0 reviews
 
First Name: Chris
My RZR: '10 RZRs / RZR170
Member #13350
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 72
View SPCAS40's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

Just ordered my intake about 10min ago for the 170. Got about 2 hours of easy time on it but not taking any chances on that intake.
__________________
2010 RZR-S (x2), RZR170 pulled by my trusty '02 Cummins 2500 which is almost broke in
Reply With Quote
  #6  
Old February 14th, 2010, 08:11 PM
TahoeTracker's Avatar
Feedback Score: 0 reviews
 
Member #7644
Join Date: May 2009
Posts: 129
View TahoeTracker's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

Smart man...which one did you go with?...Just curious.
Reply With Quote
  #7  
Old February 14th, 2010, 08:15 PM
SPCAS40's Avatar
Feedback Score: 0 reviews
 
First Name: Chris
My RZR: '10 RZRs / RZR170
Member #13350
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 72
View SPCAS40's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

Went with the Vent Racing setup and also the engine filter as well. Figured if I was ordering might as well get both at the same time.
Looks like your running the same setup S for me and my Wife, 170 for the kids....until the Wife take over the S she seems to be enjoying to much and then I'll probably get her a std RZR so I can squeeze it on the truck
__________________
2010 RZR-S (x2), RZR170 pulled by my trusty '02 Cummins 2500 which is almost broke in
Reply With Quote
  #8  
Old February 15th, 2010, 05:13 AM
PA18D's Avatar
Feedback Score: 0 reviews
 
First Name: Dave
My RZR: Red '09 800, Liquid Silver LE '12 900XP
Member #6741
Join Date: Mar 2009
Location: Battle Creek, MI
Posts: 65
View PA18D's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

Similar problem..kids rode it 2 weekends, cleaned the filter each day after riding..dusty. Started to sputter at the end of the second weekend..took to dealer and 3 months later (after riding season here) it was rebuilt. This winter have added factory UTV intake and snorkeled CVT..bring on the dust now (FYI..the intake has perked this thing up).
Reply With Quote
  #9  
Old February 16th, 2010, 03:58 PM
linrobelf's Avatar
Team Orange Crush
Feedback Score: 0 reviews
 
First Name: Linda, Robert or Kids
My RZR: Rzr 800 LE, Rzr 170 Dirty
Member #13176
Join Date: Feb 2010
Location: Kent, Washington
Posts: 17
View linrobelf's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

Well we decided to bring it back from the shop and wait for a big bore kit to come available. we found one from Martin Racing but it was only 170cc just one cc more than stock.We are realy gonna go big on it including graphics from AMR racing and bighorn 23's mounted up on12X7 duglas diablos in the mashined finish AS WELL AS raptor 660 shoks to give it some lift. will keep youguys updated.
Reply With Quote
  #10  
Old February 16th, 2010, 04:49 PM
SPCAS40's Avatar
Feedback Score: 0 reviews
 
First Name: Chris
My RZR: '10 RZRs / RZR170
Member #13350
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 72
View SPCAS40's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

Hey, Maybe between the 2 of us we can make one working RZR170....unless your steering box is busted too.
__________________
2010 RZR-S (x2), RZR170 pulled by my trusty '02 Cummins 2500 which is almost broke in
Reply With Quote
  #11  
Old March 14th, 2010, 03:11 PM
linrobelf's Avatar
Team Orange Crush
Feedback Score: 0 reviews
 
First Name: Linda, Robert or Kids
My RZR: Rzr 800 LE, Rzr 170 Dirty
Member #13176
Join Date: Feb 2010
Location: Kent, Washington
Posts: 17
View linrobelf's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

Yeah!!!! The sun has come out!!!!!!! We got a message from our Dealer that Polaris is going to cover the full cost to fix the engine. We should have it back by Friday of this week. Either the dealer or myself will install the Vent after market parts before we ever ride it.
Reply With Quote
  #12  
Old March 14th, 2010, 03:25 PM
mikes's Avatar
Premium Member
Feedback Score: 0 reviews
 
First Name: Mike
My RZR: 2010 S orange madness
Member #10540
Join Date: Oct 2009
Location: Latrobe, PA
Posts: 142
View mikes's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

Good to hear, I am glad polaris is fixing your problem In this day and age it is hard to get a manufacture to do what wright and fix there wrongs. It comes down to nobody cares any more. It is ashame. I am happy for you.
Reply With Quote
  #13  
Old March 15th, 2010, 03:23 PM
TahoeTracker's Avatar
Feedback Score: 0 reviews
 
Member #7644
Join Date: May 2009
Posts: 129
View TahoeTracker's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

That's awesome that they are gonna fix it. I have heard horror stories of trying to get warranty work approved. Anyway, congrats and order up yourself intake, skidplate, and you will be good to go. If you go with a Vent Racing kit, let me know what size jets it comes with. I have th FUTV intake and running a 127.5 main jet (not positive what size pilot) but I think I gotta go bigger, little hesitation/sputter on take off.
Reply With Quote
  #14  
Old May 24th, 2010, 08:30 AM
TINYTIM's Avatar
Feedback Score: 0 reviews
 
Member #15645
Join Date: May 2010
Posts: 4
Garage
View TINYTIM's Photo Gallery(0)
Re: 170 Engine troubles!!!!!!!!

I bought a 170 used with 4 months warranty remaining. It ran OK when I picked it up, but after riding awhile it started smoking bad. Took to dealer they rebuilt the engine under warranty and sold me a snorkel intake and modified my exhaust. After less than three tanks of fuel its smoking worse than ever, my son is 9 and he has a ball driving this thing but I can't get it rebuilt every 2 months. I was told that the intake would help and I didn't really need a filter on the cooling fan.
Reply With Quote
  #15  
Old March 4th, 2011, 07:05 PM
orangecrush's Avatar
Official Parts Breaker
Premium Member
Feedback Score: 20 reviews
 
First Name: Mark
My RZR: 2013 Jagged X
Member #21745
Join Date: Jan 2011
Location: Charlotte, NC
Posts: 4,550
View orangecrush's Photo Gallery(20)
Re: 170 Engine troubles!!!!!!!!

I know this is an old post but if it is starting to smoke, are the rings (bore) shot already? Too little, too late??

I started up my daughter’s 170 today and noticed it was smoking at start-up... much like a chevy V8 that needs valve seals... (only on start up)

I guess once it starts to smoke on start up, I guess the damage is done?

Thanks,

Mark
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris RZR Forum - RZR Forums.net > General RZR > RZR 170 Specific Disccusion


Search tags for this page
does polaris rzr 170 have a polaris engine
,
polaris 170 engine
,
polaris 170 smoking
,

polaris razor 170 engine

,

polaris rzr 170 engine

,
polaris rzr 170 engine cooling
,

polaris rzr 170 engine problems

,
polaris rzr 170 motor
,

polaris rzr 170 problems

,

polaris rzr 170 smoking

,

rzr 170 engine

,

rzr 170 problems

,
rzr 170 smokes
,

rzr 170 smoking

,
rzr170 smoking
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone had troubles with tilt steering ram? pipedup General RZR Discussion 19 March 12th, 2010 08:55 PM
Utv Crap is having phone troubles! dirtysidedown UTV Inc 0 September 11th, 2009 04:30 PM
Transmission Troubles Muddin800RZR Engine and Drivetrain 0 January 31st, 2009 04:20 PM
???'s with Dealership troubles. fireman660r General RZR Discussion 3 July 22nd, 2008 07:23 PM
Rzr Troubles Stroker General RZR Discussion 8 July 4th, 2008 09:52 AM

All times are GMT -7. The time now is 09:34 PM.




Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.