170 Engine troubles!!!!!!!! - Polaris RZR Forum - RZR Forums.net

RZR 170 Specific Disccusion For all discussions about our little buddy - the Polaris RZR 170 and the RZR 170 EFI!

 
LinkBack Thread Tools Display Modes
post #1 of 15 Old February 14th, 2010, 05:42 PM Thread Starter
Team Orange Crush
Feedback Score: 0 reviews
 
linrobelf's Avatar
 
Join Date: Feb 2010
Location: Kent, Washington
Posts: 17
Dollarsign 170 Engine troubles!!!!!!!!

Any one elese out here have problems with thier 170's lossing compression and starting to smoke. Also what kind of riding conditions do you ride with your 170?
linrobelf is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old February 14th, 2010, 06:05 PM
Feedback Score: 0 reviews
 
TahoeTracker's Avatar
 
Join Date: May 2009
Posts: 132
Re: 170 Engine troubles!!!!!!!!

I'm sure you changed the intake before you let the kids ride it....right??? If not, there is your answer. If you have changed it, well I don't know for sure. My kids 170 is ridden in Nevada...VERY DUSTY! and no problems with the new intake system by Factory UTV IF still under warranty, take it back to your dealer and let them fix it. Hope you get to the bottom of it.
TahoeTracker is offline  
post #3 of 15 Old February 14th, 2010, 06:56 PM Thread Starter
Team Orange Crush
Feedback Score: 0 reviews
 
linrobelf's Avatar
 
Join Date: Feb 2010
Location: Kent, Washington
Posts: 17
Re: 170 Engine troubles!!!!!!!!

No we didnt put on the intake before going to the dunes, BIG mistake. After only 10 hours in the dunes the bore is ruined and there is no compression and it burnes oil. regretting not puting on the vent racing intake before going thanx for your concern and input.
linrobelf is offline  
Sponsored Links
Advertisement
 
post #4 of 15 Old February 14th, 2010, 07:53 PM
Feedback Score: 0 reviews
 
TahoeTracker's Avatar
 
Join Date: May 2009
Posts: 132
Re: 170 Engine troubles!!!!!!!!

Pretty sad that all the rzr's have such junk for an intake. You would think that they would be able to fix the issue after so many complaints and issues with it. Hard to believe after spending thousands of dollars on a UTV you have to go buy an aftermarket product to make the thing run correctly. I will say that I love my "S" and the kids love their 170
TahoeTracker is offline  
post #5 of 15 Old February 14th, 2010, 08:01 PM
Feedback Score: 0 reviews
 
SPCAS40's Avatar
 
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 72
Re: 170 Engine troubles!!!!!!!!

Just ordered my intake about 10min ago for the 170. Got about 2 hours of easy time on it but not taking any chances on that intake.

2010 RZR-S (x2), RZR170 pulled by my trusty '02 Cummins 2500 which is almost broke in
SPCAS40 is offline  
post #6 of 15 Old February 14th, 2010, 08:11 PM
Feedback Score: 0 reviews
 
TahoeTracker's Avatar
 
Join Date: May 2009
Posts: 132
Re: 170 Engine troubles!!!!!!!!

Smart man...which one did you go with?...Just curious.
TahoeTracker is offline  
post #7 of 15 Old February 14th, 2010, 08:15 PM
Feedback Score: 0 reviews
 
SPCAS40's Avatar
 
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 72
Re: 170 Engine troubles!!!!!!!!

Went with the Vent Racing setup and also the engine filter as well. Figured if I was ordering might as well get both at the same time.
Looks like your running the same setup S for me and my Wife, 170 for the kids....until the Wife take over the S she seems to be enjoying to much and then I'll probably get her a std RZR so I can squeeze it on the truck

2010 RZR-S (x2), RZR170 pulled by my trusty '02 Cummins 2500 which is almost broke in
SPCAS40 is offline  
post #8 of 15 Old February 15th, 2010, 05:13 AM
Feedback Score: 0 reviews
 
PA18D's Avatar
 
Join Date: Mar 2009
Location: Big Rapids, MI
Posts: 77
Re: 170 Engine troubles!!!!!!!!

Similar problem..kids rode it 2 weekends, cleaned the filter each day after riding..dusty. Started to sputter at the end of the second weekend..took to dealer and 3 months later (after riding season here) it was rebuilt. This winter have added factory UTV intake and snorkeled CVT..bring on the dust now (FYI..the intake has perked this thing up).
PA18D is offline  
post #9 of 15 Old February 16th, 2010, 03:58 PM Thread Starter
Team Orange Crush
Feedback Score: 0 reviews
 
linrobelf's Avatar
 
Join Date: Feb 2010
Location: Kent, Washington
Posts: 17
Re: 170 Engine troubles!!!!!!!!

Well we decided to bring it back from the shop and wait for a big bore kit to come available. we found one from Martin Racing but it was only 170cc just one cc more than stock.We are realy gonna go big on it including graphics from AMR racing and bighorn 23's mounted up on12X7 duglas diablos in the mashined finish AS WELL AS raptor 660 shoks to give it some lift. will keep youguys updated.
linrobelf is offline  
post #10 of 15 Old February 16th, 2010, 04:49 PM
Feedback Score: 0 reviews
 
SPCAS40's Avatar
 
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 72
Re: 170 Engine troubles!!!!!!!!

Hey, Maybe between the 2 of us we can make one working RZR170....unless your steering box is busted too.

2010 RZR-S (x2), RZR170 pulled by my trusty '02 Cummins 2500 which is almost broke in
SPCAS40 is offline  
post #11 of 15 Old March 14th, 2010, 03:11 PM Thread Starter
Team Orange Crush
Feedback Score: 0 reviews
 
linrobelf's Avatar
 
Join Date: Feb 2010
Location: Kent, Washington
Posts: 17
Re: 170 Engine troubles!!!!!!!!

Yeah!!!! The sun has come out!!!!!!! We got a message from our Dealer that Polaris is going to cover the full cost to fix the engine. We should have it back by Friday of this week. Either the dealer or myself will install the Vent after market parts before we ever ride it.
linrobelf is offline  
post #12 of 15 Old March 14th, 2010, 03:25 PM
Feedback Score: 0 reviews
 
mikes's Avatar
 
Join Date: Oct 2009
Location: Latrobe, PA
Posts: 142
Re: 170 Engine troubles!!!!!!!!

Good to hear, I am glad polaris is fixing your problem In this day and age it is hard to get a manufacture to do what wright and fix there wrongs. It comes down to nobody cares any more. It is ashame. I am happy for you.
mikes is offline  
post #13 of 15 Old March 15th, 2010, 03:23 PM
Feedback Score: 0 reviews
 
TahoeTracker's Avatar
 
Join Date: May 2009
Posts: 132
Re: 170 Engine troubles!!!!!!!!

That's awesome that they are gonna fix it. I have heard horror stories of trying to get warranty work approved. Anyway, congrats and order up yourself intake, skidplate, and you will be good to go. If you go with a Vent Racing kit, let me know what size jets it comes with. I have th FUTV intake and running a 127.5 main jet (not positive what size pilot) but I think I gotta go bigger, little hesitation/sputter on take off.
TahoeTracker is offline  
post #14 of 15 Old May 24th, 2010, 08:30 AM
Feedback Score: 0 reviews
 
TINYTIM's Avatar
 
Join Date: May 2010
Posts: 4
Garage
Re: 170 Engine troubles!!!!!!!!

I bought a 170 used with 4 months warranty remaining. It ran OK when I picked it up, but after riding awhile it started smoking bad. Took to dealer they rebuilt the engine under warranty and sold me a snorkel intake and modified my exhaust. After less than three tanks of fuel its smoking worse than ever, my son is 9 and he has a ball driving this thing but I can't get it rebuilt every 2 months. I was told that the intake would help and I didn't really need a filter on the cooling fan.
TINYTIM is offline  
post #15 of 15 Old March 4th, 2011, 07:05 PM
Official Parts Breaker
Feedback Score: 21 reviews
 
orangecrush's Avatar
 
Join Date: Jan 2011
Location: Charlotte, NC
Posts: 4,813
Re: 170 Engine troubles!!!!!!!!

I know this is an old post but if it is starting to smoke, are the rings (bore) shot already? Too little, too late??

I started up my daughter’s 170 today and noticed it was smoking at start-up... much like a chevy V8 that needs valve seals... (only on start up)

I guess once it starts to smoke on start up, I guess the damage is done?

Thanks,

Mark
orangecrush is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone had troubles with tilt steering ram? pipedup General RZR Discussion 19 March 12th, 2010 08:55 PM
Utv Crap is having phone troubles! dirtysidedown UTV Inc 0 September 11th, 2009 04:30 PM
Transmission Troubles Muddin800RZR Engine and Drivetrain 0 January 31st, 2009 04:20 PM
???'s with Dealership troubles. fireman660r General RZR Discussion 3 July 22nd, 2008 07:23 PM
Rzr Troubles Stroker General RZR Discussion 8 July 4th, 2008 09:52 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome