No Power - Polaris RZR Forum - RZR Forums.net

Lighting, Stereo and Electrical For discussion of lighting, stereo and other electrical components

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old July 13th, 2010, 05:29 AM Thread Starter
 
polaristracker's Avatar
 
Member #7056
Join Date: Mar 2009
Posts: 8
Feedback Score: 0 reviews
View polaristracker's Photo Gallery(0)
No Power

Here's the deal. I installed the large battery kit for my RZR and had a left over generic optima battery that I placed in there. The battery had sat for a year (unfortunately) but I thought it should still have some life left because I bought it new.
Anyways I noticed if I let the RZR sit for more than a day, I had to jump the battery to get it started (I wanted to buy a new battery next paycheck). So this last time I jumped it when I removed the jumper cables it shut off. I went to turn it over again and no luck. I was frustrated so I went out that day and bought an Optima battery. After installing the battery I turned the key to prime (power was on) but when I went to turn for ignition all power went out. I checked the battery all is good, all wires and connections at the battery are good (ground good). Starter fires like a champ when a direct wire to the positive on the battery.
I have not put a multitester (need to get one) to the voltage regulator or alternator and to truly test the alternator I probably need to take it out and get it tested at an auto parts store. However I am guessing it is the voltage regulator, because if it was the alternator wouldn't I get some power DC from the battery and when I went to turn the key to turn over the engine then it would be a no go?
FYI my voltage regulator is located in front of the radiator?
ANy suggestions or advise is welcome
THX
polaristracker is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old July 13th, 2010, 06:12 AM
Official Site Vendor
 
swingarm1's Avatar
 
First Name: Tim
My RZR: TAGTEAM APEX / UTVINC / COGNITO / STM / HOLZ / GNS / $$$$ EDITION
Member #7690
Join Date: May 2009
Location: PRESCOTT, ARIZONA (928) 273-4249
Posts: 41,116
Feedback Score: 176 reviews
View swingarm1's Photo Gallery(1)
Re: No Power

Quote:
Originally Posted by polaristracker View Post
Here's the deal. I installed the large battery kit for my RZR and had a left over generic optima battery that I placed in there. The battery had sat for a year (unfortunately) but I thought it should still have some life left because I bought it new.
Anyways I noticed if I let the RZR sit for more than a day, I had to jump the battery to get it started (I wanted to buy a new battery next paycheck). So this last time I jumped it when I removed the jumper cables it shut off. I went to turn it over again and no luck. I was frustrated so I went out that day and bought an Optima battery. After installing the battery I turned the key to prime (power was on) but when I went to turn for ignition all power went out. I checked the battery all is good, all wires and connections at the battery are good (ground good). Starter fires like a champ when a direct wire to the positive on the battery.
I have not put a multitester (need to get one) to the voltage regulator or alternator and to truly test the alternator I probably need to take it out and get it tested at an auto parts store. However I am guessing it is the voltage regulator, because if it was the alternator wouldn't I get some power DC from the battery and when I went to turn the key to turn over the engine then it would be a no go?
FYI my voltage regulator is located in front of the radiator?
ANy suggestions or advise is welcome
THX
Check your starter / brake switch located under the seat on the main frame rail behind the battery... Also check the sarter diode on the fire wall by the fuse box...
swingarm1 is offline  
post #3 of 3 Old July 13th, 2010, 06:48 AM
 
bwinkl04's Avatar
 
First Name: Brian
My RZR: '10 RZR S
Member #16740
Join Date: Jul 2010
Location: Tinley Park, IL
Posts: 84
Feedback Score: 0 reviews
View bwinkl04's Photo Gallery(0)
Re: No Power

yep, if the battery is new and has 12 - 14 volts, and the starter will turn over when you direct wire it, but not with the key, then it's not the voltage reg. or alternator. Alternator only keeps the battery charged.

If you have a continuity tester, you can test the ignition switch.

When looking at the back of the switch, you should see 6 pins on the switch... call these, from left to right, a - f.
- with the switch in off position, you should have continuity between e and f (last two pins).
- with the switch in on position, you should have continuity between c and d (middle two pins).
- with the switch in on position, you should have continuity between a and f (first pin, last pin).
- with the switch in start position, you should have continuity between a and b (first two pins).
- with the switch in start position, you should have continuity between c and d (middle two pins).

Also, when you direct wired it, did you go to the starter, or the starter solenoid? if you follow the heavy positive wire back for the starter, you should come to the solenoid (sorry, I'm not sure where it is located). there should be 2 heavy gauge wires connected, and a plug with 2 small gauge wires. if you unplug the small wire and put 12volts to on, and ground to the other, will the starter turn? if not, thats your problem.
bwinkl04 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for power gskaggs12 Engine and Drivetrain 1 March 14th, 2010 11:15 PM
More Power digarcia1987 Engine and Drivetrain 13 February 23rd, 2010 05:29 AM
need more power mikemnkt Forced Induction 2 December 8th, 2009 10:35 AM
RzR Power? 98rickstang General RZR Discussion 12 September 20th, 2009 05:02 PM
rzr s needs some power bigguyrides RZR-S Specific Discussion 9 March 3rd, 2009 07:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome