Not Charging????? - Polaris RZR Forum - RZR Forums.net

Lighting, Stereo and Electrical For discussion of lighting, stereo and other electrical components

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old April 26th, 2008, 06:24 PM Thread Starter
 
ThirtyftFL's Avatar
 
Member #2215
Join Date: Apr 2008
Posts: 7
Feedback Score: 0 reviews
View ThirtyftFL's Photo Gallery(0)
Ace Not Charging?????

Hi guys, just joined. I got my rzr last week and tonight was my first night ride. Well, I went about 3 miles when the battery light came on. I checked the voltage and it was about 10.5 so I headed back home. I just about made it back, backfireing and sputtering half the way and the voltage was at 8.4 when I got home. Any one else have this problem or no of a fix. I don't want to wait a month for the dealer to get me in. thanks
ThirtyftFL is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old April 26th, 2008, 09:39 PM
 
BigSilly450X's Avatar
 
First Name: John
My RZR: 2016 XPT4 & 2008 RZR800
Member #56
Join Date: Apr 2007
Location: Sloughhouse, CA
Posts: 1,141
Garage
Feedback Score: 0 reviews
View BigSilly450X's Photo Gallery(0)
Re: Not Charging?????

If your dealer take a month to get you in you bought from the wrong dealer. Sounds like your stator is not working. It needs to go in to the dealer. Post more details. Have you added lights, etc?
BigSilly450X is offline  
post #3 of 6 Old April 26th, 2008, 10:25 PM
 
TEXMudder's Avatar
 
Member #1840
Join Date: Mar 2008
Posts: 49
Feedback Score: 0 reviews
View TEXMudder's Photo Gallery(0)
Re: Not Charging?????

Is your regulator rectifier plugged in? It is behind the driver seat close to the outside. Silver box around 4x4x2. There are two plugs going to it.
TEXMudder is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old April 27th, 2008, 05:07 AM Thread Starter
 
ThirtyftFL's Avatar
 
Member #2215
Join Date: Apr 2008
Posts: 7
Feedback Score: 0 reviews
View ThirtyftFL's Photo Gallery(0)
Re: Not Charging?????

I will check the rectifier. There are no extra electrical accessories. I forgot to mention too that the tach and hour meter stopped woring as welll, odometer and clocl works fine. I didn't talkt to the dealer as It just started happening last night, and they will hear it from me if they don't make room for it.
ThirtyftFL is offline  
post #5 of 6 Old April 27th, 2008, 05:20 AM Thread Starter
 
ThirtyftFL's Avatar
 
Member #2215
Join Date: Apr 2008
Posts: 7
Feedback Score: 0 reviews
View ThirtyftFL's Photo Gallery(0)
Talking Re: Not Charging?????

Update: I turns out it was the rectifier Thanks TEXMudder. Yesterday I was sure I checked all the plugs, guess I missed that one.
ThirtyftFL is offline  
post #6 of 6 Old April 27th, 2008, 08:04 AM
Mad Scientist
 
martymoe's Avatar
 
First Name: Marty
My RZR: 08 RZR 800 & 12 RZR XP & 16 XP Turbo
Member #385
Join Date: Sep 2007
Location: Wylie, TX
Posts: 1,246
Garage
Feedback Score: 0 reviews
View martymoe's Photo Gallery(7) Send a message via MSN to martymoe Send a message via Yahoo to martymoe
Re: Not Charging?????

the tach not working is a good indicator of a problem with the voltage regulator. the digital dash gets it's rpm input from the voltage regulator. it doesnt make sense but thats where it comes from.
i guess the cps with it's missing tooth signal is harder for the digital dash to read.
martymoe is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Charging a Optima blcoonrod Lighting, Stereo and Electrical 5 November 8th, 2008 08:43 AM
any upgrades for the stock charging system? megadesertdiesel Lighting, Stereo and Electrical 19 April 29th, 2008 08:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome