Leaking radiator fluid again... - Polaris RZR Forum - RZR Forums.net

General RZR Discussion For General Polaris RZR discussion

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old November 11th, 2011, 08:40 AM Thread Starter
 
Bull Hog Grande's Avatar
 
Member #24879
Join Date: Apr 2011
Posts: 115
Feedback Score: 0 reviews
View Bull Hog Grande's Photo Gallery(0)
Leaking radiator fluid again...

Bought 2011 RZR and started leaking anti freeze on second ride. Dealer came and picked up and replaced radiator. I only have 11 hours on it since April and just climbed out of it and its leaking radiator fluid again. I cant find a leak and the connections are all good. I know alot of people have had this issue. When it leaks its not alot, it no more than a 1/4 cup. It looks like its just overflow. Does anyone have any information on this ? What is wrong recall etc ??
Bull Hog Grande is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old November 12th, 2011, 07:51 AM
Premium Member
 
RWTDCT's Avatar
 
First Name: Robert
My RZR: 2014 XP4 1000 - Titanium
Member #21382
Join Date: Jan 2011
Location: Paso Robles, CA.
Posts: 6,715
Feedback Score: 4 reviews
View RWTDCT's Photo Gallery(15)
Re: Leaking radiator fluid again...

I have the rzr 4. After approx 15 to 20 hrs. I inspected the whole rzr from top to bottom side to side. I took the under belly off (skid plate) I noticed two places where the coolant was leaking. There is a metal pipe with rubber hoses in a couple sections with hose clamps that runs from your radiator to the motor. All I needed to do was tighten down the clamps, it cured the problem.

Not sure if your might have same problem, but a place to start.

Last edited by RWTDCT; November 12th, 2011 at 07:54 AM. Reason: addition
RWTDCT is offline  
post #3 of 5 Old November 12th, 2011, 08:33 AM
 
Waistdeep's Avatar
 
My RZR: 2011 RZR Camo
Member #18687
Join Date: Sep 2010
Location: British Columbia, Canada
Posts: 242
Feedback Score: 0 reviews
View Waistdeep's Photo Gallery(0)
Re: Leaking radiator fluid again...

i had the same thing happen on mine, seemed like it was either overflowing or coming from the connections right at the rad. After the 3rd time to the dealer they were able to sort it out and corrected the problem. No issues now - oh yea, other than the water pump seal that leaked oil over the bottom of the motor. they said that was due to a pitted water impellar, fixed that and now no problems
Waistdeep is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old November 12th, 2011, 08:33 AM
 
2011 RZR 800's Avatar
 
First Name: Kerry
My RZR: 2011 800 RZR 50
Member #23427
Join Date: Mar 2011
Location: King,NC
Posts: 706
Feedback Score: 1 reviews
View 2011 RZR 800's Photo Gallery(9)
Re: Leaking radiator fluid again...

mine had a leak right where the lines start under the body and all i did was tighten the clamps up then went through all of them and tighten them up,also system might just need to be burped if it's coming from over flow.
2011 RZR 800 is offline  
post #5 of 5 Old November 12th, 2011, 10:16 AM Thread Starter
 
Bull Hog Grande's Avatar
 
Member #24879
Join Date: Apr 2011
Posts: 115
Feedback Score: 0 reviews
View Bull Hog Grande's Photo Gallery(0)
Re: Leaking radiator fluid again...

Thanks guys. I refilled the resevoir and took for a.ride. Dripped a little bit again. I just sent the thing to the dealer for first oil/fluid change. First ride back it started.
Bull Hog Grande is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
crap....im leaking transmission fluid. help! evilking General RZR Discussion 8 March 14th, 2012 06:10 AM
Purple tinted fluid leaking bonny RZR XP 900 6 April 24th, 2011 07:09 PM
2 rzr "s"s leaking tranfer case fluid!! razrface RZR-S Specific Discussion 3 April 24th, 2010 08:44 AM
why is my radiator overflo leaking pawngod Engine and Drivetrain 10 March 22nd, 2010 08:46 PM
Transmission Vent leaking fluid - Normal? 2fiftyR Engine and Drivetrain 2 October 7th, 2009 06:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome