rzr problems!!! - Polaris RZR Forum - RZR Forums.net

General RZR Discussion For General Polaris RZR discussion

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old July 16th, 2008, 09:23 PM Thread Starter
 
cali-boi's Avatar
 
Member #3150
Join Date: Jul 2008
Posts: 42
Garage
Feedback Score: 0 reviews
View cali-boi's Photo Gallery(0)
rzr problems!!!

In The First Two Months Ive Had Some Problems. First One Almost Kept Me From Going To My First Trip To Sand Mountain Nv. That Was My Rear Inner Cv Boot That My Brake Line Crept Up And Rubbed On Enough To Rip The Boot In Half. Keep An Eye On Thoes Lines. Then After Two Weeks Of Waiting On The New Boot I Finally Got It In Twenty Minutes Before We Left. Then Out There My Low Batt Light Came On From My Stereo While Riding And Awd Would Not Kick In Until Going Fast. Thennnn When I Was Wayyy Out From Camp My Pully On My Clutch Froze Up And Burnt My Belt Off. And To Top It Off A Rhino And A 4wd Quad Both Pulled Me Home. Shity Story Right. O Well I Get My Rzr Back From The Shop In 2 Days!!!
cali-boi is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old July 16th, 2008, 11:22 PM
 
jajl22's Avatar
 
First Name: Jason
My RZR: 2014 XP1k LT
Member #554
Join Date: Nov 2007
Location: Peoria,Az
Posts: 656
Feedback Score: 0 reviews
View jajl22's Photo Gallery(0)
Re: rzr problems!!!

my advice to you is dont go to VEGAS BABY!! because that is some bad luck. Hopefully your next trips out are much more pleasent
jajl22 is offline  
post #3 of 5 Old July 17th, 2008, 04:41 AM
 
YOTTER's Avatar
 
Member #3322
Join Date: Jul 2008
Posts: 5
Feedback Score: 0 reviews
View YOTTER's Photo Gallery(0)
Re: rzr problems!!!

anyone had problems with the rzr front end, or hubs? with 5.4hrs on it

Last edited by YOTTER; July 17th, 2008 at 04:46 AM.
YOTTER is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old July 17th, 2008, 07:06 AM
 
RZRwanter0019's Avatar
 
Member #2075
Join Date: Apr 2008
Posts: 27
Feedback Score: 0 reviews
View RZRwanter0019's Photo Gallery(0)
Re: rzr problems!!!

I had the same problem! brake line rubbed through the cv boot. I fixed in in the parking lot. a Polaris 800 quad cv boot fit perfect! but now the cv is clicking and making noise, so the shop has it.

Im not sure why but I have never seen the low battery light. I have a amp and always use it! guess im lucky!!
RZRwanter0019 is offline  
post #5 of 5 Old July 17th, 2008, 08:48 AM
 
MBRider85's Avatar
 
First Name: Blake
Member #1590
Join Date: Mar 2008
Location: Manitoba, Canada
Posts: 87
Feedback Score: 0 reviews
View MBRider85's Photo Gallery(0)
Re: rzr problems!!!

My regulator failed and was replaced at 600 miles. They also replaced my stator just to be safe.

08' RZR
2" RubberDown Lift
27" XTR on 14" Crushers
Bimini Top
1/2 Windshield
Trail Armor Frt Bumper
MBRider85 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Awd problems mxhunter147 General RZR Discussion 5 February 8th, 2009 03:01 PM
Key problems anyone have them jrsabot Member Introductions 5 December 24th, 2008 07:26 AM
Shifting problems IMF Engine and Drivetrain 25 December 19th, 2008 02:19 PM
? cv problems JOKER Engine and Drivetrain 0 November 11th, 2008 01:26 PM
Air Box Problems rzrgriff Engine and Drivetrain 36 April 17th, 2008 08:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome