2010 razor will not idle - Polaris RZR Forum - RZR Forums.net

Engine and Drivetrain For discussion of drivetrain and engine performance and maintenance

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old November 25th, 2012, 06:59 PM Thread Starter
 
malibu05's Avatar
 
Member #12718
Join Date: Jan 2010
Posts: 5
Feedback Score: 0 reviews
View malibu05's Photo Gallery(0)
2010 razor will not idle

Need help, this weekend razor just stalled will not start unless gone it gas then as soon as u let off it stalls. What could this be
malibu05 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old November 25th, 2012, 07:29 PM
Owner-Light it Up Offroad
 
MATT1524's Avatar
 
First Name: Matt
My RZR: 2016-Turbo 4
Member #13639
Join Date: Feb 2010
Location: Fort Smith, Arkansas
Posts: 12,681
Feedback Score: 16 reviews
View MATT1524's Photo Gallery(0)
Fuel pump. My 2010 did same thing. Check fuel pressure. Common problem.

We Sell: Totron, Viper, Rigid, PRP & MORE!
CALL 479-222-5398
479-434-4161

WWW.GETLITFS.COM

Your one stop shop for all your UTV & Truck needs!

We have a REAL store front!
3201 Wheeler Ave-Fort Smith, Arkansas
MATT1524 is offline  
post #3 of 7 Old November 25th, 2012, 07:50 PM
Official Site Vendor
 
Hunterworks's Avatar
 
First Name: Todd
My RZR: 2016 XP1000
Member #47437
Join Date: Nov 2012
Location: Collinsville, MS
Posts: 8,163
Feedback Score: 7 reviews
View Hunterworks's Photo Gallery(0)
Re: 2010 razor will not idle

Does it run fine otherwise? Normally and I say normally a weak fuel pump allows it to idle but not come to speed.

I would say a place to start looking is the throttle sensor voltage out of whack or a issue with the idle speed control valve.

www.hunterworks.com

Todd
Office phone: 601-771-0070
Hunterworks is online now  
Sponsored Links
Advertisement
 
post #4 of 7 Old November 25th, 2012, 08:51 PM
 
RacerSam's Avatar
 
My RZR: 2009 Nuclear Orange LE, 2012 Walker Evans
Member #7858
Join Date: May 2009
Location: Central City KY
Posts: 1,477
Feedback Score: 0 reviews
View RacerSam's Photo Gallery(0)
Re: 2010 razor will not idle

our 09 did that one day ,I changes spark plugs, and checked most everything short of actual TPS voltage, as I went to loosen clamp where T.B. goes into intake boot from air cleaner to clean it, the T.B. just feel down, turns out if was lose/slide out of the intake manifold side already. put it back into intake boot on engine side, tightened clamp, then back in intake boot to airbox, ran like new again.

on a sie note ours had been idle-ing low like 950-1050 rPM's after the intake boot fix that was lose, guess got loser/came out finally that day messing up its idle sucking air into engine there. it also fixed the low idle.

'16 Graphite Crystal turboXP
'14 Black Stealth 900XP
'12 Walker Evans 800
'09 Nuclear Orange 800LE SOLD
'11 rzr170 SOLD
'05 YFZ450 SOLD
RacerSam is offline  
post #5 of 7 Old November 27th, 2012, 07:01 PM Thread Starter
 
malibu05's Avatar
 
Member #12718
Join Date: Jan 2010
Posts: 5
Feedback Score: 0 reviews
View malibu05's Photo Gallery(0)
Re: 2010 razor will not idle

Thanks for the help. For the most part as long as u stay in the throttle it runs ok, little on the rough side but will run. As soon as you let off the gas it shuts right off. Does any one know if a fuel pump out of a 2011 S will fit. When i cross reference the polaris part#s they are not the same but is that the case, or is that just a polaris thing.
Thanks again for the help.
malibu05 is offline  
post #6 of 7 Old November 27th, 2012, 07:31 PM
 
RacerSam's Avatar
 
My RZR: 2009 Nuclear Orange LE, 2012 Walker Evans
Member #7858
Join Date: May 2009
Location: Central City KY
Posts: 1,477
Feedback Score: 0 reviews
View RacerSam's Photo Gallery(0)
Re: 2010 razor will not idle

Quote:
Originally Posted by malibu05 View Post
Thanks for the help. For the most part as long as u stay in the throttle it runs ok, little on the rough side but will run. As soon as you let off the gas it shuts right off. Does any one know if a fuel pump out of a 2011 S will fit. When i cross reference the polaris part#s they are not the same but is that the case, or is that just a polaris thing.
Thanks again for the help.
think for an 11 or 12 pump to work, you will also need an 11 or 12 fuel tank too

'16 Graphite Crystal turboXP
'14 Black Stealth 900XP
'12 Walker Evans 800
'09 Nuclear Orange 800LE SOLD
'11 rzr170 SOLD
'05 YFZ450 SOLD
RacerSam is offline  
post #7 of 7 Old November 27th, 2012, 09:37 PM
 
MotoXXX's Avatar
 
First Name: Jeff
My RZR: 2014 XP1K Black Pearl LE
Member #4542
Join Date: Sep 2008
Location: Oregon
Posts: 6,014
Garage
Feedback Score: 26 reviews
View MotoXXX's Photo Gallery(40)
Re: 2010 razor will not idle

Have you checked the fuel pressure or the TPS voltage yet?
MotoXXX is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 razor S Factoryride250 Polaris RZRs For Sale 11 September 27th, 2012 06:17 PM
2010 rzr s 800 low idle?? jordan07 RZR-S Specific Discussion 1 April 9th, 2012 08:18 PM
2010 rzr s TPS and idle ? BMRZRS RZR-S Specific Discussion 7 March 28th, 2012 08:30 PM
Razor S wont idle Blown Razor RZR-S Specific Discussion 8 February 13th, 2011 05:11 AM
2010 Razor S belt help Goodtimes RZR-S Specific Discussion 4 May 17th, 2010 07:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome