Polaris RZR Forum

acceleration problem

This is a discussion on acceleration problem within the Engine and Drivetrain forums, part of the Technical category; yesterday we had a race at durhamtown plantation (I took 2nd out of 9) but i didnt finish the last lap witch did not matter ...


Go Back   Polaris RZR Forum - RZR Forums.net > Technical > Engine and Drivetrain

Engine and Drivetrain For discussion of drivetrain and engine performance and maintenance

Reply
 
LinkBack Thread Tools Display Modes
Old November 11th, 2012, 06:02 PM   #1
Feedback Score: 0 reviews
 
VBDracing8's Avatar
 
First Name: Brendan
My RZR: XP 900 Liquid Silver
Member #44860
Join Date: Sep 2012
Location: South Carolina
Posts: 158
View VBDracing8's Photo Gallery(0)
Rzr Icon acceleration problem

yesterday we had a race at durhamtown plantation (I took 2nd out of 9) but i didnt finish the last lap witch did not matter but after going threw where the pits are i gave it gas around the flat track and it did not go there was no acceleration.

so i thought it was gas (only had 2 bars) so i went to the pits and all was fine for about a mile or so until it did it again and the steering got wobbley and it would barley go forward it will move forward and back but will not accelerate.

thought i burned the belt but we inspected and nothing looked wrong. also i screwd up my cv joint. today i was going up the dirt driveway to show my dad and when i let off the pedal it made a noise that the rzr makes when turning to sharp on concrete. so i was wondering what the problem was. and i hope you guys can help.

Thanks
Brendan

Last edited by VBDracing8; November 11th, 2012 at 06:04 PM. Reason: didnt finish
VBDracing8 is offline   Reply With Quote
Sponsored Links
RZRForums.net is the premier Polaris RZR Forum on the internet. Registered Users do not see these ads. Please Register - It's Free!
Reply

Lower Navigation
Go Back   Polaris RZR Forum - RZR Forums.net > Technical > Engine and Drivetrain

Tags
belt, need help, problem


Search tags for this page

2012 polaris 800 ranger acceleration problem

,

acceleration polaris

,

honda gl500 no acceleration

,

polaris accelatorproblems razor

,

polaris burning belt when accelerating

,

polaris engine acceleration problem

,

polaris ranger has no power when accelerating

,

polaris ranger no acceleration power

,

polaris ranger no acceleration problem

,

polaris rzr no aceleration

,

ranger 900 no acceleration

,

rzr 800 no acceleration

,

rzr acceleration

,

rzr has no acceleration

,

rzr4 problem accelerates

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
08 RZR Acceleration Uneven Macs Dad General RZR Discussion 4 August 23rd, 2010 08:46 PM
Codes 51/52. Acceleration problem..... MDEVO Engine and Drivetrain 5 August 22nd, 2010 02:11 PM
slippage on very low acceleration RZR 4 ROCKSTAR Engine and Drivetrain 4 April 21st, 2010 01:27 PM
New RZR and acceleration hancop General RZR Discussion 11 April 16th, 2010 05:50 PM
Acceleration for my 09 RZR mister General RZR Discussion 17 March 2nd, 2009 06:43 AM

All times are GMT -7. The time now is 11:32 PM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.