2012 RZR another problem - Polaris RZR Forum - RZR Forums.net

Engine and Drivetrain For discussion of drivetrain and engine performance and maintenance

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old April 3rd, 2012, 04:04 PM Thread Starter
 
Murphytom24's Avatar
 
Member #33834
Join Date: Dec 2011
Posts: 14
Garage
Feedback Score: 0 reviews
View Murphytom24's Photo Gallery(0)
2012 RZR another problem

so every once in awhile my rzr will be hard to start, once it starts it sounds like its only running on one cylinder but its not, i hit the gas and it stalls, then when i try to start it again it whirls over like it has no compression eventually it will start again, after a long period of starting and stalling it will eventually start like nothing is wrong and runs like a champ, i bought it in dec 2012, 17 hours in the cam lobes wore off and polaris rebuilt the motor for no charge, it has about 180 miles on it now havent had any other problems, yes i took the junk champion plugs out and put NGK irdium plugs in it, yes the air filter is clean, no i havent had it in any water or mud, i just trail ride it, any ideas? thanks for your time
Murphytom24 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old April 3rd, 2012, 04:09 PM
King of crash!
 
johnnycat8's Avatar
 
First Name: john
My RZR: 2nd gen...red
Member #787
Join Date: Dec 2007
Location: roseville calif.
Posts: 31,885
Garage
Feedback Score: 9 reviews
View johnnycat8's Photo Gallery(0) Send a message via Yahoo to johnnycat8
Re: 2012 RZR another problem

the oil pressure regulator pin likes to stick on the 800 get a new one or try to clean it up with some crockus cloth. not sure how to spell it.

link for crow dog's site!!! www.utvguide.net


running makin trax afco shocks and springs
johnnycat8 is offline  
post #3 of 9 Old April 3rd, 2012, 04:44 PM Thread Starter
 
Murphytom24's Avatar
 
Member #33834
Join Date: Dec 2011
Posts: 14
Garage
Feedback Score: 0 reviews
View Murphytom24's Photo Gallery(0)
Re: 2012 RZR another problem

ok, where is that located, im not familiar with it.
Murphytom24 is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old April 3rd, 2012, 04:50 PM
 
redrzrrider's Avatar
 
First Name: Butch
My RZR: 2012 LE
Member #17841
Join Date: Aug 2010
Location: Washburn Wisconsin
Posts: 649
Feedback Score: 0 reviews
View redrzrrider's Photo Gallery(0)
Re: 2012 RZR another problem

There is a thread on this about 10 pages deep with the same problem, most on 2012 and 2011 models, when they changed the fuel pump. I think we have it narrowed down to a heat issue with the injectors or a possible ECU programing issue. I'm personally waiting for it to warm up so I can test it again. Also, many think it's ethenol fuel. Try premium and see if that helps.
I will locate the thread and bring it back to the top so watch for it in the active topics.

UPDATE....the thread is 18 pages deep. The topic is "hard to start when warm".
redrzrrider is offline  
post #5 of 9 Old April 9th, 2012, 01:30 PM Thread Starter
 
Murphytom24's Avatar
 
Member #33834
Join Date: Dec 2011
Posts: 14
Garage
Feedback Score: 0 reviews
View Murphytom24's Photo Gallery(0)
Re: 2012 RZR another problem

So I located this valve where the dowl pin is located, took the cap off took the spring out but can't get the pin out, is it magnetic? Is it brass? Should I crank the motor over and hope the oil pressure just blows the dowl out? and once I get it out is there a "fix" or am I gonna have to do this every 150 miles, this blows, I bought a new one for a reason, thank you all for your input it's very helpful
Murphytom24 is offline  
post #6 of 9 Old April 9th, 2012, 01:47 PM
 
slider_buck's Avatar
 
My RZR: 2012 60" SATV Kit LE
Member #36277
Join Date: Feb 2012
Location: chillicothe, oh
Posts: 379
Garage
Feedback Score: 2 reviews
View slider_buck's Photo Gallery(0)
Re: 2012 RZR another problem

read this topic. sounds exactly what you have going on.


http://www.rzrforums.net/general-rzr...when-warm.html
slider_buck is offline  
post #7 of 9 Old April 9th, 2012, 03:58 PM Thread Starter
 
Murphytom24's Avatar
 
Member #33834
Join Date: Dec 2011
Posts: 14
Garage
Feedback Score: 0 reviews
View Murphytom24's Photo Gallery(0)
Re: 2012 RZR another problem

Mine only does it after it sits over night, I never have a problem when it's hot, once I get it started its fine all day, but every morning it seems to take about 20 mins to get it going
Murphytom24 is offline  
post #8 of 9 Old April 16th, 2012, 01:21 PM Thread Starter
 
Murphytom24's Avatar
 
Member #33834
Join Date: Dec 2011
Posts: 14
Garage
Feedback Score: 0 reviews
View Murphytom24's Photo Gallery(0)
Re: 2012 RZR another problem

Ok as a close for this thread, I located the oil pressure relief valve, pulled the dowl pin out and shined it like glass and put it back together, and now my RZR runs like a champ ALL the time. I can't believe something so small can cause such BIG problems and I still can't wrap my head around how it made it do what it did but it's fixed so I hope this thread will help others, and now I'm gonna make a new thread about another problem ha ha thanks everyone
Murphytom24 is offline  
post #9 of 9 Old April 18th, 2012, 08:31 PM
 
wes31123's Avatar
 
First Name: wes
Member #31293
Join Date: Oct 2011
Location: logan wv
Posts: 36
Garage
Feedback Score: 0 reviews
View wes31123's Photo Gallery(0)
Re: 2012 RZR another problem

how did u get the dowl pin out
wes31123 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
DIRTFEST 2012 at Speedworld January 21, 2012 racespeedworld Local Rides and Events 3 January 20th, 2012 08:13 PM
clutch problem on 2012 razr le eps goat2789 Engine and Drivetrain 21 January 11th, 2012 02:09 PM
Major problem with our 2012 RZR XP 900 TigeDuner RZR XP 900 19 January 10th, 2012 05:32 PM
2012 intake problem adamr General RZR Discussion 5 January 6th, 2012 08:17 PM
2012 rzr randomly died - problem found!!!!! Orangemadness12 Engine and Drivetrain 4 October 30th, 2011 09:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome