Overheating 800 - Page 3 - Polaris RZR Forum - RZR Forums.net

Engine and Drivetrain For discussion of drivetrain and engine performance and maintenance

Reply
 
LinkBack Thread Tools Display Modes
post #31 of 34 Old October 3rd, 2012, 05:42 AM
Feedback Score: 0 reviews
 
boatms's Avatar
 
Join Date: Apr 2011
Posts: 68
Re: Overheating 800

Ok guys I changed the thermostat and the impeller. Filled the system and vented according to the service manual. Ran it in my shop for about an hour and it cycles just as it is supposed to I guess the thermostat was bad the old impeller looked as good as the new one.
boatms is offline  
Sponsored Links
Advertisement
 
post #32 of 34 Old October 29th, 2012, 01:55 PM
all4down
Feedback Score: 0 reviews
 
all4down's Avatar
 
Join Date: Jun 2011
Location: home of the Steelers
Posts: 11
Re: Overheating 800

I also had a overheating problem in my '11 razor this past weekend.I have 1100 miles on it and it started cutting out on me,looked over, engine overheat light was on,toggled to the display and temp read 245 deg. Fan was running intermitten at this time,wired it direct and used the foglights toggle so I could turn off and on.Worked for about 3 hours then overheated with fan on.Noticed coolant leaking out of the weep hole on the bottom of the pump.Took out thermostat,threw it in boiling water,opened fine.Rad perfectly clean but water isn't circulating.Impeller doesn't explain why the fan run but shut off before engine was able to cool.Has anyone seen a impeller go bad? Leaks like a cars pump when it goes bad but not built the same way.Totally lost here on this one,hopefully someone can shed some light.
all4down is offline  
post #33 of 34 Old January 7th, 2013, 09:29 AM
Feedback Score: 3 reviews
 
RZRTOURS's Avatar
 
Join Date: Apr 2011
Location: LAS VEGAS, NV
Posts: 685
Re: Overheating 800

Quote:
Originally Posted by all4down View Post
I also had a overheating problem in my '11 razor this past weekend.I have 1100 miles on it and it started cutting out on me,looked over, engine overheat light was on,toggled to the display and temp read 245 deg. Fan was running intermitten at this time,wired it direct and used the foglights toggle so I could turn off and on.Worked for about 3 hours then overheated with fan on.Noticed coolant leaking out of the weep hole on the bottom of the pump.Took out thermostat,threw it in boiling water,opened fine.Rad perfectly clean but water isn't circulating.Impeller doesn't explain why the fan run but shut off before engine was able to cool.Has anyone seen a impeller go bad? Leaks like a cars pump when it goes bad but not built the same way.Totally lost here on this one,hopefully someone can shed some light.
Yes, Impellers do go bad. We have had to replace a few. You probably got air in your system when you over heated. Also, if you have coolent leaking out of the weep hole down by the water pump, that means your water pump seal is bad. That will have to be changed to correct that problem. Impeller can be changed at the same time.
RZRTOURS is offline  
Sponsored Links
Advertisement
 
post #34 of 34 Old October 14th, 2013, 02:59 PM
Feedback Score: 0 reviews
 
catman1120's Avatar
 
Join Date: Jul 2011
Location: raleigh nc
Posts: 22
Re: Overheating 800

hey i just got back from trailfest in wv and my rzr give me some trouble overheating. this was the first time in 4000 miles. i ride hard and have minor mods done to engine. here is the kicker it only runs hot under steady throttle, i can gag the sh#$ out of it for hours in the mountains but as long as i get in and out of the throttle but if you demand a steady rpm it starts cooking, removed t-stat but no change im thinking impellor is worn but have not tore it down yet, anyone seen this issue? also rad. is clean and no air in system thanks in advance

DONE 4 FUN!!!!!!!
catman1120 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Overheating?? RZRBound Engine and Drivetrain 18 February 20th, 2017 02:04 AM
anyone having overheating problems????? bs250r Engine and Drivetrain 14 August 27th, 2012 05:46 PM
Need help with overheating! Halloween_Nut Engine and Drivetrain 19 July 19th, 2012 06:32 AM
overheating rzr103 Engine and Drivetrain 2 February 20th, 2011 03:56 PM
rzr overheating rickmaley Engine and Drivetrain 8 April 14th, 2009 05:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome