Codes 51/52. Acceleration problem..... - Polaris RZR Forum - RZR Forums.net

Engine and Drivetrain For discussion of drivetrain and engine performance and maintenance

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old August 5th, 2010, 07:17 AM Thread Starter
 
MDEVO's Avatar
 
My RZR: 08 RZR with some goodies
Member #9586
Join Date: Sep 2009
Location: Oshawa, Ontario, Canada
Posts: 16
Feedback Score: 0 reviews
View MDEVO's Photo Gallery(0)
Codes 51/52. Acceleration problem.....

My 08 Gen 2 started sputtering under hard acceleration, so I checked the codes and found 51/52/25. I serched and found lots of info on fuel pump issues so I think that may be the issue, just trying to find a gauge to measure fuel pressure. It starts fine and does not fall on its face untill I hit the throttle to the floor. I looked at the wiring harness and checked around for grounding issues but found nothing. Gona order a fuel pump just incase......

Any other suggestions?

Thanks....

THE ONE WITH THE MOST TOYS WHEN HE DIES
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>WINS
MDEVO is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old August 5th, 2010, 08:18 AM
 
bagman's Avatar
 
My RZR: 2015 1K Havasu Red
Member #649
Join Date: Dec 2007
Location: Norco, CA
Posts: 2,114
Garage
Feedback Score: 0 reviews
View bagman's Photo Gallery(0)
Re: Codes 51/52. Acceleration problem.....

You need a gage with a connector to attach to the schrader valve on the fuel rail.

I bought the master kit from Harbor Freight that has all kinds of attachments. Used it several times now for mine and other RZR's.

Good chance it is your pump. You want 39psi on the rail.

Just saw your from Canada. What do you have, Northern tool up there??? Harbor Freight of the North.
bagman is offline  
post #3 of 6 Old August 19th, 2010, 07:54 PM Thread Starter
 
MDEVO's Avatar
 
My RZR: 08 RZR with some goodies
Member #9586
Join Date: Sep 2009
Location: Oshawa, Ontario, Canada
Posts: 16
Feedback Score: 0 reviews
View MDEVO's Photo Gallery(0)
Re: Codes 51/52. Acceleration problem.....

Finally had time to put the new fuel pump in, and test her out. NO CHANGE! It is still hesitating/popping upon hard accelleration around 4500rpm. I added more fuel with the controller and it did not seem to help much. Back to the drawing board I guess.

What other issues arise from the code 51/52. Do the injectors go bad?
Id hate to have to bring it to the dealer............. help please!

THE ONE WITH THE MOST TOYS WHEN HE DIES
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>WINS
MDEVO is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old August 19th, 2010, 08:19 PM
 
Banshee84's Avatar
 
First Name: Andy
My RZR: RZR S
Member #7051
Join Date: Mar 2009
Location: Franklinton LA.
Posts: 170
Feedback Score: 0 reviews
View Banshee84's Photo Gallery(7)
Re: Codes 51/52. Acceleration problem.....

I'm not at the shop but i believe 51 and 52 is injector 1 & 2 short to ground or short to hot. Code 25 is temp. sensor short to ground or short to hot. Had a rzr give me these codes after a motor rebuild. Found it was a bad conection at the the solenoid. Be sure to check all major power conections hot and grounds. Hope this helps.
Banshee84 is offline  
post #5 of 6 Old August 19th, 2010, 09:15 PM
 
rzrnaz's Avatar
 
My RZR: 2014 XP4k
Member #1446
Join Date: Feb 2008
Location: Tucson, AZ
Posts: 617
Feedback Score: 0 reviews
View rzrnaz's Photo Gallery(0)
Re: Codes 51/52. Acceleration problem.....

Had the same codes and it was a loose ground at the battery.

2010 S
DynoJet PC-V with autotune module
HIDs from Endi at Sidexside Customs
Makin Trax progressive springs
Opti-Air 600 filter with in-bed mount
25" Haulers
Axia Alloys Mounts
LE33 Weekend Warrior
rzrnaz is offline  
post #6 of 6 Old August 22nd, 2010, 01:11 PM Thread Starter
 
MDEVO's Avatar
 
My RZR: 08 RZR with some goodies
Member #9586
Join Date: Sep 2009
Location: Oshawa, Ontario, Canada
Posts: 16
Feedback Score: 0 reviews
View MDEVO's Photo Gallery(0)
Re: Codes 51/52. Acceleration problem.....

Thanks for the replys.
I found the problem, the G3 DFR fuel controler! Figures...last thing I looked at.

Not sure why it is causing the problem, guess I'll call DFR and see if it can be fixed.

Cheers

THE ONE WITH THE MOST TOYS WHEN HE DIES
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>WINS
MDEVO is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
slippage on very low acceleration RZR 4 ROCKSTAR Engine and Drivetrain 4 April 21st, 2010 12:27 PM
New RZR and acceleration hancop General RZR Discussion 11 April 16th, 2010 04:50 PM
codes rzrwrecker General RZR Discussion 10 March 19th, 2009 06:38 AM
Acceleration for my 09 RZR mister General RZR Discussion 17 March 2nd, 2009 05:43 AM
codes pateneaude_34 Engine and Drivetrain 3 September 15th, 2008 01:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome